JavaScript Mode removed?

edited August 2015 in JavaScript Mode

Am I understanding correctly from that there is no more JavaScript Mode in newer versions of Processing? I miss it already! Are there any plans to put it back? Am I missing a good explanation somewhere for why it's gone?

Former ProcessingJS mode (Processing 1.5) that became JavaScript mode (Processing 2.0 beta) that has now been moved out of the Processing IDE.


  • edited August 2015

    That's just a bad formed sentence. Just meant it was PROMOTED as a JavaScript MODE for Processing 2.

    On the other hand, JavaScript MODE was indeed DEMOTED this year as an "official" Processing project;
    being replaced by p5.js instead!

  • Okay, I'm still confused. Can I use JS Mode in Processing 3.0a11? If so, how?


  • Anything past Processing 3.0a5 is utterly different from Processing had been.
    B/c from 3.0a6 and on, class PApplet doesn't inherit from Java's Applet anymore.
    Much probably it won't work. But you've gotta check it for yourself!

  • Ack. I mean, I tried to check for myself before I came here for help; I was hoping there was some solution to the fact it didn't work at all.

  • I'm going to try tagging @fjen here (does that work?) - I may need to go back to an older version of Processing if I can't get processing.js working in the new one...

  • Answer ✓

    Yes, worked. … i just did not update it yet to work with 3.x. Will do soon and let you know here.

  • Great!

  • Started to work on this but turns out not to be as trivial as i hoped … i'll keep you posted.

  • Thanks for the update @fjen!

  • Thanks @fjen : I performed a light test (ellipse, rect, colorMode, translate, rotate), and it seems to work quite fine.

  • Answer ✓

    Great, thanks

  • @fjen, How do I install this into Processing? I can use it with 3.0.2, correct? Thank you!

  • Similar to installing a library but use the "modes" folder:

  • Hi and thanks for your work on this. I put the JavaScriptMode folder in the "modes" folder, and I see it listed when I go to the "add mode" option in Processing 3.0.2 but it is grayed out. Any further suggestions for me would be appreciated! I like to be able to post sketches to the Open Processing website and then embed them in blog posts...

  • Make sure it's the "modes\" subfolder from your sketchbook path.
    Don't mess w/ the subfolders where Processing was installed.

  • I'm pretty sure it's in the correct folder. I am on a Mac, and the path I'm on is documents/Processing/modes/JavaScriptMode

  • In order to make sure that is indeed your sketchbook folder's location, hit CTRL + COMMA.

  • All of my sketches are being routed (and saved in folders) to documents/Processing --and that's where I find the 'modes' and 'libraries' folders as well. I have tried putting the JavaScriptMode folder in the 'modes' folder, and I have also tried putting it in the 'libraries' folder, both to no avail. Where would I hit CNTL + COMMA to verify this as the correct spot? Thanks...

  • edited March 2016

    I dunno how CTRL + COMMA would be translated to a Mac OS.
    But we can always click at File -> Preferences too.

    In my system it is: "sketchbook path"/modes/JavaScriptMode/

  • I checked via File -> Preferences, and I am using the correct Processing folder. Onto the next possibility I guess. When I try to 'add mode' I see JavaScriptMode listed but it is grayed out. When I select it the message returned is '0.3.3 not compatible.' Would you recommend I just start over by re-downloading the new mode and trying again? Thx...

  • I've manually copied the folder "JavaScriptMode/" into "modes/" when i was using v3.0.0 w/ PDE closed.

    When I run PDE again, it was already there installed w/ green status as v0.4.0.
    Only still grayed out mode is CoffeeScript though.

  • Thanks so much, I will try that next...

  • Just passing along good news. I re-downloaded JavaScriptMode and put it in the Processing 'modes' folder. This time, however, I did this with the PDE closed. Just as you said GoToLoop, when I next opened Processing the Javascript option was available. Thanks again!

  • Hi, I have just installed this folder in the modes folder and it works a treat. Brilliant work. However, I'm having problems in the sketches that run off .csv files. There is nothing shown in the screen with these. Is there a way to get around this?

  • You may have noticed that even @fjen 0.4.0 version of JavaScriptMode no longer works with Processing 3.3.3. Well, I think this is the workaround:

    Inside your documents/processing3/modes/JavaScriptMode/template folder, create (another) new folder called template and move processing.js and template.html into it. One level above, create a blank file called sketch.pde

    The way that templating was done was changed around 9 months ago, and this has been crapping out due to the sketch.pde file being not found.

  • serial library doesn't work in javascript. Any solution

Sign In or Register to comment.