processing on ARM

Hi, I am trying to get processing up and running on my beagle board, i know its possible but for the life of me i can't figure out how to do it, i have oracle JDK installed but how do you link it to processing? and how do you tell processing where it is? i have got it up and running on my pi but it's too slow, if anyone has any ideas please throw them my way, i've speant the past 2 weeks trying to get this going.............



  • edited October 2013

    I installed processing on my Chromebook, which also uses ARM. I'll be curious to hear if you're able to install it using the same directions and I would love to hear how it runs. Here's how I did it, using the 32bit Linux version of Processing:

    I found that openJDK runs super slow when doing certain tasks, like drawing ellipses. So I figured out how to install Oracle's Java JDK for ARM, which works much better:

    1. Download the "Linux ARM v6/v7 VFP Hard Float ABI" from this page:

    2. Move the downloaded file to the /usr/lib/jvm directory. The terminal command, if you are in your downloads folder is: sudo mv jdk-7u40-linux-arm-vfp-hflt.tar.gz /usr/lib/jvm

    3. Move to that directory: cd usr/lib/jvm

    4. Untar the package: sudo tar zxvf jdk-7u40-linux-arm-vfp-hflt.tar.gz

    5. Delete the java folder inside of your Processing folder

    6. Go back to your processing folder and make a symlink to java: ln -s /usr/lib/jvm/jdk1.7.0_40 java

  • hello! I am also trying to install Processing on my BeagleBoard. nicklally, I just followed your instructions exactly. when I try to run Processing, I get:

    root@beaglebone:~/Desktop/processing/processing-2.0.3-linux32# ./processing
    root@beaglebone:~/Desktop/processing/processing-2.0.3-linux32# ./processing: line 117: /usr/lib/jvm/jdk1.7.0_40/bin/java: No such file or directory

    the jvm directory did not already exist, so I had to create it. what do you think?

  • i will give this ago next week and get back to you thanks! On another note i'm also planning on getting a intel galileo board to see if it will run any quicker on there! i will get back to you next with with my Beagle bone findings Thanks!!

  • Hi Thanks, this also worked on my UDOO board which uses a ARM but i cant get the processing video library to work or start a webcam. Anybody got anyluck with that?

  • Has this moved on in the last 8 months? I've just got a Beaglebone Black and was hoping for some pointers to help me get Processing up and running on it. Thanks :)

  • edited August 2015

    I'm trying to get processing to work on my arm chromebook. It tries to launch, but comes up with the error "Could not find required fonts. Please reinstall processing"

    I am using Ubuntu with xfce4. I'll update if I get it to work.

  • Well I just got it to work.

    I found a "fonts" folder in the java directory that comes with processing. I moved it to my oracle java jre directory and that worked.

  • When I try to launch it comes up with /usr/lib/jvm/jdk1.8.0_144/bin/java: 1: /usr/lib/jvm/jdk1.8.0_144/bin/java: Syntax error: word unexpected (expecting ")")

    I am using a Ubuntu with xfce4. The only difference from the approach from nicklally is that I had to download a newer version of inux ARM v6/v7 VFP Hard Float ABI, because the website said this version is not longer current. Can somebody help me?

Sign In or Register to comment.