Problem with library manager

edited November 2014 in Using Processing

Hi, Trying to install a library however when I open library manager on both my laptop and desktop I get the same error "Error in contribution listing file on line 1" is this something up with my processing (somehow on both machines) or is it issue with processing library repository? Any help is appreciated!



  • Same problem here! running Processing 2.2.1 on two WIN machines. My guess is that Javascript permissions are preventing Processing from accesing the libraries properly; however, I haven't been able figure out exactly what the problem is (I have re-checked and Java and its dependencies are in EVERY exception list - firewall, antivirus, etc., and SHOULD run correctly)

  • Hey, wish i could help. don't really know what the problem is. If you want to install a library go to documents then go to processing then in the folder where all your sketches are there should be a folder that says "libraries" if not, create one that says "libraries" the copy your installed library into it. But, i don't know if that is the problem. So could you specify?


  • Hi TechWiz,

    Well in my case, and I'm almost certain is the same with the original poster, whenever I try to search/install a library from the Library Manager under the Skecth tab, the console displays the following error: "Error in contribution listing file on line 1" and the manager only shows the libraries I installed manually, but can't seem to connect to the server and display other libraries, so the download feature from the Manager is disabled (I added a picture to show the problem)Pro-ErrorLibrary

    The manual installation works as usual, which is a workaround, but I'm concerned as to why a core feature is not working properly and if other malfunctions under the hood may eventually cause more serious problems - like not running a skectch correctly.

  • Thanks, the picture helps a lot. I did not answer your question. For that, I am sorry. I think it could be a problem with processing in general, but I to am using 2.2.1 and have no problems installing and managing libraries. Maybe it's because I'm on a windows xp and you are on a 7.

  • Hey, I have the same issue. I was trying to get open processing for kinect to work and some how after that the library manger decided to give me the same message. Somehow he doesn't seem to acknowledge anything in library.

    (Which is odd because the manager worked fine when I was got the KinectJNI, after I tried adding OpenKinect did the misbehaving seem to start.)

    Anyways, I tried manually removing and re-adding the libraries I have. Also re-installing processing in general and the error still persists.

    My operating system is Win 8.1 Pro. !Screenshot (14)

  • edited October 2014

    I also have the problem wit the modes. I tried it on windows 8.1 64bit and win 7 32bit everytime the same mistake with every release it doesnt matter if its 2.2.1 or 3. processing error

  • Hey regarding the post before hand, I meant SimpleOpenNI not KinectJNI. (In case that is relevant).

    I managed to organize the library so he does recognize simpleopenni, but not openkinect for processing. Aasnd... the error is still there.

  • I am using Processing 2.2.1 on OSX 10.9.7 and this message appears as soon as you select

    Add library

    Add mode

    Add tool

    this is before you attempt to select a library/mode/tool so the actual library/mode/tool you are interested in has no affect.

    It is obviously a problem related to Processing and not to a particular OS or setup.

  • edited October 2014

    Do u know when the bug-update appears master quark? :)

  • For me this issue appeared very randomly and across all devices, 4 PCs with windows 7, 8, 8.1 and OSX mavericks. Obviously adding libraries manually is a work around but rather inconvenient if the libraries are hard to find on github etc. Seems as if this is a fairly common issue so hopefully will get resolved quickly.

  • Answer ✓

    Hi there, I just downloaded Processing 2.2.1 on OSX 10.10 (Yosemite) and i experienced exactly the same issue, not being able to download external libraries from Processing. By reading the message, the file related to contributions is corrupted or missing, so I checked in the configuration folder: /Users/yourusername/Library/Processing/

    and there you find a file named contributions.txt which appears to be an html file (by reading its content) saying that the actual contributions.txt file is missing and has been moved there: (this one, the real one, does not have an html-like content )

    You can replace the corrupted file by it's online version and then re-run Processing, then it works. But note that on the next launch of Processing, this file will again be replaced by its html-false-brother, dont know why but it seems to work anyway... (if not, make a script that copy the original file and then run Processing...)

    If you are not on OSX and are looking for this configuration folder, you can find its address by opening Processing > Preferences > Bottom of the window

    Until the next update, it should do the job,



  • Cheers for the update, good to know! Hope a more stable fix is released soon though!

  • Thanks Jonathan that worked great for me.

    For anyone else using Linux the configuration folder will be under your home directory.


  • Hi everyone
    same problem here : mode manager does not list the android mode.
    Manual install is possible (the file was not easy to find though...) but I would like to fix the "normal" process (mode manager).
    I found a contributions.txt on the web but it does not have any link to android mode.
    is it possible to edit this file - and by the way where am I supposed to save it, so Processing finds it and gives me all the possible modes ?

Sign In or Register to comment.