Exported program fails silently

edited March 2018 in Arduino

Hello, I exported the Adafruit's Adalight program to have LEDs behind the TV with my Arduino, however the program fails at launch. In the task manager, I see Java running for about a second then disappearing.

I have tried the 32 and 64 bits versions, including Java or not and restarting my computer.

I tried looking for a log with a crash dump file or something, but I can't find anything, including on the only documentation page I found there: https://github.com/processing/processing/wiki/Export-Info-and-Tips



  • I exported the Adafruit's Adalight program to have LEDs behind the TV with my Arduino

    Zero experience with the Adalight... can you comment what it is and what is its role in your setup? Is it a stand alone system similar to a raspberry-pi? What is the display of that device? Or are you running the Processing sketch in headless mode?


  • Hello there! Thanks for your answer, it is that code so you can just copy paste in a new sketch and try to export: https://github.com/adafruit/Adalight/blob/master/Processing/Adalight/Adalight.pde

  • @NaturalBornCamper

    Are you running this exported sketch on a Raspberry Pi computer? (asking because this is the Raspberry Pi section of the forum) If so, which exported version of the sketch are you trying to execute? (you mentioned 32 and 64 bit earlier) Are you running the "linux-armv6hf" one?

  • From that file:

    // "Adalight" is a do-it-yourself facsimile of the Philips Ambilight concept
    // for desktop computers and home theater PCs.  This is the host PC-side code
    // written in Processing, intended for use with a USB-connected Arduino
    // microcontroller running the accompanying LED streaming code.  Requires one
    // or more strands of Digital RGB LED Pixels (Adafruit product ID #322,
    // specifically the newer WS2801-based type, strand of 25) and a 5 Volt power
    // supply (such as Adafruit #276).  You may need to adapt the code and the
    // hardware arrangement for your specific display configuration.
    // Screen capture adapted from code by Cedrik Kiefer (processing.org forum)

    @NaturalBornCamper -- have you tried opening an issue?

  • Sorry @gohai I have no idea how I selected Raspberry Pi, I must have clicked it by mistake or didn't notice it was set to that category. I'm using an Arduino Uno.

    @jeremy I didn't try to open an issue as this code seems abandoned. Anyways it's working, I got my lights working and all, was just trying to export into a .exe to avoid opening Processing every time. However I'm wondering if it's because I'm using Processing 2 (As per the Adafruit instructions). There could be a bug in the export function.

    I'm trying with Lightpack now, since there is an interface with a standalone .exe file and more controls. Just got to make sure the serial communication works and I'll let you guys know. If this work, I won't even need to use Processing for that specific project anymore :)

  • I managed to make it work with Prismatik lightpack guys! So no worries about the export issue anymore. Thanks for all your help and have a great weekend!

Sign In or Register to comment.