GUI Builder error on start

edited March 2015 in Library Questions

Hello, I don't understand why when I start GUI Builder, I can create the gui.pde tab, I restart processing to get the tab appear on the sketch, then when I want to start GUI Builder from tools menu, It says "An error occurred inside Gui Builder" and with the following log :


G4PTool V2.5 created by Peter Lager writing aborted; at at at at at at at javax.swing.ActionMap.readObject( at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke( at sun.reflect.DelegatingMethodAccessorImpl.invoke( at java.lang.reflect.Method.invoke( at at at at at at at javax.swing.JComponent.readObject( at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

Thanks for help



  • I have deleted a lot of the log because it starts to repeat itself, it doesn't help me much and I hate scrolling. ;)

    Which version of Processing are you using?

  • Hello,

    It happens on Processing 3.0a5, 3.0a4, and 2.2.1...

  • The first launch of GUI Builder works, but then I save, quit and restart Processing and the error happens

  • Oh, and I work on Mac OS X (Yosemite 10.10.2)

  • I know there are problems using GUI Builder with Processing V3 alpha releases and I will attempt to resolve the issues when Processing 3 gets out of the testing phase and released.

    I have tested GUI Builder using Processing 2.2.1 on OSX 10.9.5 and it works fine (save / close / open / restart GUI Builder).

    It could be an Apple <> Java thing because the first list is talking about

    Did it work before upgrading to Yosemite?

  • I haven't test it before upgrading to Yosemite, sorry. But it's exactly the same error like this one :

  • Same error message and possibly the same cause but unfortunately there was no definitive solution in that old post.

    You can still get problems if you attempt to edit a GUI design created with an earlier version of GUI Builder. If you haven't upgraded GUI Builder recently I have no idea what is causing the error.

    Unfortunately since I can't reproduce the problem I can't work on a solution. :(

  • Ok, too bad. I'll try on a windows machine and see if it happens too

  • Finally, it works on Windows 7 with Processing 3.0a5... No luck with the Mac version

  • Thanks for letting us know. Must be a Mac <> Java thing then.

  • It seems to be an error when writing the java file signature for the gui or something like that

Sign In or Register to comment.