Permissions Issue when Exporting File (Eclipse - OSX)

edited September 2014 in Using Processing

I've transferred a number of projects from a Windows Eclipse workspace to an OSX system. The projects run fine but I'm unable to Export frames/PDFs (Which worked fine on Windows).

Stack Trace snippet: /aaaaa.png (Permission denied) at Method) at at at processing.core.PApplet.createOutput( at processing.core.PImage.saveImageIO( at at processing.core.PApplet.saveFrame( at TestC.draw( at processing.core.PApplet.handleDraw( at processing.core.PGraphicsJava2D.requestDraw( at at .... (etc)

Skeleton code creating the error: import processing.core.PApplet;

@SuppressWarnings("serial") public class TestC extends PApplet {

public void setup() {
    size(800, 800);

public void draw() {
    ellipse(width/2, height/2, 200, 200);


I've set permissions to 777 for the eclipse & workspace directories and tried running Eclipse as root without success. saveFrame() works fine when building a sketch in Sublime Text 2.

Has anyone come across this before?


Sign In or Register to comment.