Slow performance issues

edited September 2014 in Using Processing

Hello Everyone,

I'm a newcomer to processing and facing some problems with the processing application which are :

**1- When i open processing's application it takes sometime to open .. my frame rate drops also so i can notice some jumping and slow movement of my cursor. **

2- Rendering this simple code takes more than a minute to finish !

//this is just an example of a code .. any changes have no effect on the slow/fast behavior
    size(800, 600);
    text("anything!", 400, 300);

3- I'm having this problem for around a week now .. tried everything in my reach to end it .. but all seem to be none effective with the application of processing.

Some notes :

*- I tried to install the latest java update .. and nothing happened

*- i tried to run the 32 bit version of the processing platform but for nothing also !

*- Installed the latest version of windows which is 8.1 (i was using windows 7 SP1 .. after installing win 8.1 Processing's application worked well and run so fast .. i thought it was fixed and done .. but everything returned to the normal situation without doing anything unusual or any sudden actions from my pc !

Please tell me what to do with this issue .. i'm taking a course on coursera about processing and i lost track of it because of this problem with Processing !


  • When asking for troubleshooting, it's imperative to list your main system specs!
    Like CPU, GPU, Processing version & Java version, along each of their 32/64 mode.

    Use a system info program, such as this 1 below for example, to help you collect those info:

    Also, try to run this program:

    println( javaVersionName );
    println( System.getProperty("java.home")  + "\n" );
    println( System.getProperty("os.arch") );
    println( System.getProperty("") );
    println( System.getProperty("os.version") + "\n" );
    println( System.getProperty("user.home") );
    println( System.getProperty("user.dir")   + "\n" );
    println( sketchPath );
    println( dataPath("") );
  • edited September 2014

    Thanks GoToLoop

    Processing version i'm running : processing-2.2.1-windows64

    Java version : Java 7 Update 67 (7.0.670)

    Here are my specs : Summary

    Operating System Windows 8.1 Enterprise 64-bit

    CPU Intel Core i5 3470 @ 3.20GHz 37 °C Ivy Bridge 22nm Technology

    RAM 6.00GB Dual-Channel DDR3 @ 665MHz (9-9-9-24)

    Motherboard Gigabyte Technology Co., Ltd. H61M-S2P (Intel Core i5-3470 CPU @ 3.20GHz) 28 °C

    Graphics V193HQV (1366x768@60Hz) 2048MB ATI AMD Radeon HD 7800 Series (Sapphire/PCPartner) 39 °C

    Storage 465GB Western Digital WDC WD5000AAKX-001CA0 ATA Device (SATA) 40 °C 931GB Western Digital WDC WD10EARS-00MVWB0 ATA Device (SATA) 37 °C

    Optical Drives No optical disk drives detected

    Audio Realtek High Definition Audio

    **I run the code and here is the ourput : ** 1.7.0_40 F:\Artist\GENERAL\Introduction to computional art\processing-2.2.1-windows32\processing-2.2.1\java

    Windows 8
    F:\Artist\GENERAL\Introduction to computional art\processing-2.2.1-windows32\processing-2.2.1
  • edited September 2014

    Well, I was guessing you would have a low-end graphics card. Boy, how wrong I was! :))
    Now it's just speculations ahead:

    Since you've mentioned you had installed Win8.1 very recently, it's possible you've still got an old video driver version for your HD 7xxx Series!
    Please go to and get the appropriate latest driver for your Win8.1 64-bit!

    if that wasn't enough, you may try older Processing versions and see whether they behave better!
    My favorite is the faithful v1.5.1 btW! In order to use it, make sure you've got Java JDK, and not its plain JRE version!
    Go to and pick either "jdk-7u67-windows-x64.exe" or "jdk-7u67-windows-i586.exe" installation.

    Now download P1.5.1 from here:
    Notice you don't need to get rid of other Processing versions. You can have as many as you want!
    Just keep them is their own separate folders, of course! ;)

    That's all for now! Good luck! %%-

  • Thanks alot GoToLoop again .. I'm at work now. i will try your method ASAP

  • I installed the newest AMD driver and nothing improved.

    Tried the older version of processing as you said .. and it worked very well ! Yay :D

    But i'm afraid i lost many amazing advantages from the new version 2.2.1 As i'm reading the change log .. i'm so sad of the improvements i lost !! :-(

    I'd report this issue on Github and wait till they improve it or fix this annoying problem to come back and learn :-S

    What do you think ?

  • I think that it's great you want to learn!

  • edited September 2014

    But I'm afraid I lost many amazing advantages from the new version 2.2.1...

    Don't fret too much! You can still test-drive other older versions, but newer than v1.5.1: :bz

    Good candidates are versions: 2.0.3 & 2.1.1! >-) Look! I'm still stubbornly on v2.0.2! 8-}

    And not forgetting, there's this brand new series 3 coming up! Still in alpha now though: ;;)

  • edited September 2014

    Thanks TechWiz777

    I think that it's great you want to learn!

    It's a delight for anyone on this planet to learn something new everyday :)

    Hey GoToLoop ..

    I have bad news ! :( Sadly the newest version of Processing (3) seems to have the same issue with me .. idk if it is problematic for me only or anyone else is having some issues like me with slow performance !

    Version 2.0.2 has the same issue also !!

    I didn't try 2.03 & 2.1.1 .. But i'm guessing that this problem is accompanied with Processing 2.0 and every single release above :-(

  • Well, a drastic solution would be use another OS for Processing! O:-)
    A very fast Gnu/Linux distro is LXLE:

    If you need to stick to Windows, you can use a virtual machine emulator like VirtualBox or VMware Player in order to install it:

    Once you got the OS ISO installed, you proceed the same way:

    • Uncompress Processing installation in your home folder.
    • Right-click processing launch file and Properties -> Permissions -> Execute -> Anyone.

    Make a ".desktop" launch file similar to this 1:

    [Desktop Entry]
    Name=Processing 2
    Name[en_US]=Processing 2

    Much probably OpenJDK is already installed. In case it's not:

    • Start -> System Tools -> Lubuntu Software Center.
    • Look for OpenJDK and install it.

    It's even better get ahold of Oracle's JDK. Search the Internet for How Install Oracle Java Linux!

  • edited September 2014

    GoToLoop .. Thanks alot for your much appreciated support :)

    I'm downloading VirtualBox right now, as i prefer sticking with windows

    But is it better in your opinion to use Processing on the (LXLE Gnu/Linux OS) which you referred to ? (i mean in my case not just generally .. as i'm having problems with proc.)

  • edited September 2014

    Virtual Machine emulators behave consistently b/c they all got the same virtual "peripherals".
    The make-believe "graphics card" inside the emulator got a good chance to work better!

  • I think i'm gonna try the LXLE Linux OS you told me about to finish this problem. I didn't know that VirtualBox needs an Iso file of the OS i want to use .. and i'm lazy to download something big like Mac OS X !! :D

    I learnt many stuff because of this problem with processing .. but i hope to learn proc. itself soon or i may quit at some point of frustration 8-}

    Please report this issue to the main developers so that they can fix it any time soon..

    Thanks again GoToLoop for the massive support you provided me with :x

  • edited September 2014

    It's not that big. Just 1.5 GB! :P Here's its torrent file:

    • Click "New" button or CTRL+N to start the wizard VM creation.
    • Fill in "Name" w/ "LXLE (14.04)" or something like that.
    • "Type" : "Linux"; "Version" : "Ubuntu (64 bit)".
    • "Memory Size" : 1024 MB. You can change it later!
    • "Create a Virtual Hard Drive Now". That'll become a big file the guest OS will think as a "real" HD!
    • "Hard Drive File Type" : VDI.
    • "Storage on Physical Hard Drive" : Dynamically allocated.
    • "File Allocation and Size", you can leave 8GB or 10GB since it's just for Processing.
    • After all that, you'll have a menu entry for the VM. Click @ "Display" and mark "3D Acceleration".
    • Click @ Storage and @ the CD icon and choose the downloaded ISO file.
    • Now you're ready to "Power ON" the VM machine and install the ISO inside its virtual HD.
  • edited September 2014

    I installed LXLE OS alongside my Windows 8, it's a really fast OS ! But, when i run Processing the way you detailed above a message appeared :

    Screenshot from 2014-09-26 04:35:09

    And some sketches fail to load because of this problem !

    I trid to Install the most recent update of java which is 7 but the message still appears and i still face (lots of) errors in the black part of processing's platform :

    image alt text

    Java updated as you see in the picture below :

    Screenshot from 2014-09-26 04:59:57

    Screenshot from 2014-09-26 05:26:28

    So what should i do ?

  • edited September 2014

    Hi again! I also got that annoying alert message too, since I use OpenJDK 7! X(
    I wonder if you had installed it in an emulator or for real in another partition?! <):)

    Your PC is more than capable at running even the heaviest of Linux distros.
    A safer better option is Mint Cinnamon:

    In my 64-bit Lubuntu 13.04, I've got Processing versions 2.0.2 & 1.5.1 running OK.
    1 extra step I've taken was remove their bundled "/java/" subfolder to force them to use the OS's installed Java!

    Plus what I've mentioned before, the need of setting the execution permission.
    And the ".desktop" in order to launch 'em more easily! *-:)

    If these steps above can't solve it, you might need to get Oracle's JDK version.
    Follow the instructions present in th article below:

    Good luck! Keep strong! %%-

  • edited September 2014

    Hi bro .. I tried again your method .. but still the error appears. I followed the steps the guy explained in this video

    .. the message is gone ! BUT .. the errors aren't !!!

    I can't run even one example from Processing with success !!

    I'm so sad !! i feel i'm going to stop trying soon !

    it looks like i have to give up at some point .. i lost track of my course on

    This is the course i'm doing atm ( due time passed and many people are doing great learning processing .. and i didn't learn except few stuff and stopped at the step of applying text codes to my projects !! :(( :(( :((

    Should try the (Mint Cinnamon) distro of Linux you mentioned above ?

  • You haven't told me yet whether it's running inside a VM emulator or installed for real in your PC?
    In case it's VirtualBox, it's advisable to install its VM VirtualBox Extension Pack to get more features outta it too:

    Every 1 of those errors are related to lack of permissions.
    I've already described what I did in order to run my own Processing versions:

    • Install/uncompressed it in your "/home/" folder.
    • Erase or rename bundled "/java/" subfolder to force it to use system's Java.
    • Mark execution permission for "processing" launcher script.

    That's what I do for my versions 2.0.2 & 1.5.1 in my Lubuntu distro! :(|)

    Should try the (Mint Cinnamon) distro of Linux you mentioned above?

    Only for real installation! If you still would like to try it out in a virtual machine, use its MATE version instead!

  • edited September 2014

    I installed a real OS (LXLE) alongside my Windows 8

  • edited September 2014

    Just downloaded latest stable v2.2.1 (64-bit) and run some programs!
    Seems like this version somehow demands its bundled Java in order to compile any sketch! X(
    W/o that "/java/" subfolder, the same happens to me as well! Alas... They've dumbed down OS's Java detection! :-<

  • edited September 2014

    Should try the (Mint Cinnamon) distro of Linux you mentioned above?

    For aesthetically & comfort reasons, a distro w/ a more complete desktop like Cinnamon, Mate, KDE, Unity, Gnome, is surely better! :bz

  • edited September 2014

    This is making me hate anything related to "Java" apps more :-( 8-}

    I will try another distro as you said .. i hope it works somehow :D

    Thank you for your support :)

    EDIT Why didn't you recommend using Ubuntu as it is one of Linux's distributions ?!

  • I said I was able to run v2.2.1 w/ its bundled "/java/" folder!
    Putting it back didn't work for ya? b-(

    LXLE is meant for very old PCs. That's why I've recommended it as a emulated guest OS!
    Of course it works perfectly in any behemoth of today! :P

  • edited September 2014

    I didn't try to put it back because i'm talking from work ! :)]

    I may go for Ubuntu .. i've previous experience with it, and i like it as an alternative for my main OS : Windows ! :D

  • Ubuntu uses a desktop called Unity. It's indeed much similar to Win8+'s!
    Since its launcher icons show up at the left side, it's much more adequate for laptops which doesn't have much vertical screen space!
    But if you're in a hurry, you can keep LXLE for now. It's faster & runs everything anyways! :-j

  • It didn't work on Ubuntu either !!! .. i'm gonna stick to the 1.5.1 expert version for windows and use processingjs till they fix it somehow .. i wasted lots of hours to fix this problem .. but with no income .. so i'm stopping here !

    Thanks alot GoToLoop .. your support is much appreciated :)

Sign In or Register to comment.