Controlp5 error

edited April 2014 in Library Questions

Hi, I have been using processing 2.1.1 and the latest version of controlp5. However i get the error ArrayIndexOutOfBoundsException:304 when i run the script. I can not run the even example scripts of controlpf. I can not solve the problem of my computer. Is there any idea about this incompatiblity? Thanks by now.



  • I don't think this is really a controlP5 error because it is local to your system and cannot be reproduced. You could try removing the library and reinstalling it.

  • yes, i have tried to erase and resinstall but nothing's changed. I also installed the 2.1 version of precessing, it has not worked, too.

  • I got the same error and I had an error in the code: I have 2 Arrays and used 1 array to store variable for the other, the length of these two arrays was different: since I changed them to be the same length the error was gone.

  • yes, the array length's differences creates such an outofbounds error. But i used a working code which i imported from the website of the cp5. So, i am sure that the code is correct but i still cannot run the code. there may be a java incompetibility but i dont know how i can fix.

Sign In or Register to comment.