Need urgent help in integrating google play service in My processing Android app, please.

edited March 2014 in Android Mode

My entire purpose is to integrate Admob in my app or else my entire hard-work is gone :(

Does google play service works with Processing android app, its mentioned that it will be deprecated from August 2014 ?

Do I need to use the GoogleAdmobAdsSdkAndroid-6.4.1 ?

I've been reading and watching plenty of videos since three days to figure out but I wasn't successful enough. It seems eclipse is behavingimage alt text like a bitch.

When I try to give a reference to library project : properties> Android> Add> Is library path. I did add the info and gave ok. After that I added the info in Manifest file.

Information added in manifest file:

        android:targetSdkVersion="18" />

            android:value="@integer/google_play_services_version" />


Error: No resource found that matches the name. Error: Strings type not allowed

I know why I'm getting this, actually google-play-services_lib project is not adding in my project. I dont why its like that.

I tried to clean the project nothing happened :(

But when I create android project in eclipse it works well. Problem seems to only in importing the Processing Android APP. I know I'm missing or doing something wrong. Is there any generous people her to help me its really grateful.

1) First I imported imported the google-play-service_lib in my workspace. 2) Then, I copied the lib and pasted in my lib folder. 3) I right clicked the google-play-service.jar lib and added that in my build path 4) After that I right clicked the project and went to property, added a library project google-play-service_lib to the project and then I pressed ok. (It seems everything fine)

This is the place I am totally paralysed.

5) When added the info in manifest file I got above two following errors. Then I right click my project folder to verify my property but it shows red symbol. It seems google-play-service_lib is not getting referred.

I set this version also = android:minSdkVersion to 3 nothing happened :( I followed this as bible: but still I'm stuck.

Thanks a lot in advance for your help. I'm a newbie that's why some starting issues :)



  • You can disregard the above message !

    Now I made it up and running, phew

    <activity android:name=""

    but from the above information when I compile the program it gives me different option.

    This is for less than 13 Android API. It works well When I select 13. Indeed I figured it out myself.

  • I fixed this please close this ticket !

  • Answer ✓

    This forum post isn't exactly a ticket in the issue manager sense. Indeed, the forums are often misused as a place to report issues. Simply posting that you have fixed the problem is probably sufficient. The best that you can do to mark the problem as "closed" or "solved" is to click the "Accept" button on your answer. Please keep in mind that, due to some technical issues, it is not possible to un-accept an answer...

Sign In or Register to comment.