Problem setting "available" OSC port

edited October 2017 in Android Mode


I'm trying to send OSC message to my android device but I'm getting each time BindException EADDRINUSE (address already in use). I've tried several different port numbers but it always fails...

I made sure i have the right IP, that the Internet permission is checked, I'm currently using code from this post to make sure it was not a problem with a stupid mistake.

All clues I could find were more about using directly the android SDK . I've tried to restart my phone to make sure i didn't have other app running which would use all these ports, but nothing has changed.

In the mean time, sending OSC from the android device towards my laptop works like a charm...

Any idea what else I could try?




  • In the same time, I can open a UDP port using It seems the problem would come from some incompatibility between OscP5 and the latest android mode build (0267) Any idea of an alternative OSC lib I could try?

  • I can't provide much feedback related to your OSC but I could suggest using a previous Android mode.


  • Thanks @kfrajer , i'll try that

  • So I've been trying to download and install several version of the android mode from the release page going down until latest of version 3. The problem is when i unzip the version to put it in the mode folder, some folders are missing ( like template and so I have to copy and paste it from the latest version I have, and then run in the same problem as usual... Anybody know where i could download an older version of ? I feel like the problem is coming from some file in this one...

    I've also tried to run the sketch on simulator and I ran in the same problem, while i could send without problem OSC to my phone using TouchOSC.

Sign In or Register to comment.