GSVideo and Processing 3 problem

edited September 2017 in Android Mode

hi all , i have found this library that offer video capture and playbacks and other operations , i wanted to test it in processing 3 ,but every example i try to run on my android phone it crashes at start !! the thing is i need to capture video from ip camera , i tried the IPcapture library and every thing worked fine , but the problem the processing app resolution should be the same as the camera resolution for the app to work , else it will crash , i can't show the video on my phone full screen !! i couldn't know why is that happening , so i tried the GSVideo library i thought that this would fix the problem so i added the library on my processing 3 open example , exported the apk , installed it ,but the app crashes at start always

this is the code i tried to run :

import codeanticode.gsvideo.*;

GSPipeline pipeline;

void setup() {
  size(640, 480);

  pipeline = new GSPipeline(this, "");;

void draw() {
  // When the GSPipeline.available() method returns true, 
  // it means that a new frame is ready to be read.
  if (pipeline.available()) {;
    image(pipeline, 0, 0);

Note : Processing is V3 , the phone is galaxy s6 edge with android 7.0 and i use the latest version of GSvideo library

i also tried to use apde on android to run the code , but no luck too , i got the following errors:

java.lang.nosuchfielderror: no field title of type i in class codeanticode.gsvideo.GSVideo. (Unknown source)

and many other errors !

so please anyone can help me to make the library works with me ?! or anyone can help me to find alternative library to get video and ip camera stream from url .

Kind regards


  • It was last updated in 2011 and was tested on Processing 1.5.1. This library will not work with 3.

Sign In or Register to comment.