Problems playing video on Raspberry Pi

edited December 2016 in Raspberry PI

Im running Processing v3.1.1 on a Raspberry Pi. Im really happy with it apart from one thing, playing video. I know this is possible in other software but Id really like to get it working.

Progress so far:

Added the video library and tried:


Movie test;

void setup() {
  test = new Movie(this, "launch1.mp4");

void movieEvent(Movie m) {;

void draw() {
  image(test, 0, 0, width, height);

All I get is a blank screen. Also tried adding the GL video tool. Then tried the examples that come with it but every time, I get the following error message:

libEGL warning: DRI2: failed to authenticate
java.lang.RuntimeException: java.lang.ClassNotFoundException: Failed to find NEWT Display Class <>
    at jogamp.newt.DisplayImpl.create(
    at com.jogamp.newt.NewtFactory.createDisplay(
    at com.jogamp.newt.NewtFactory.createDisplay(
    at processing.opengl.PSurfaceJOGL.initDisplay(
    at processing.opengl.PSurfaceJOGL.initFrame(
    at processing.core.PApplet.initSurface(
    at processing.core.PApplet.runSketch(
    at processing.core.PApplet.main(
Caused by: java.lang.ClassNotFoundException: Failed to find NEWT Display Class <>
    at jogamp.newt.DisplayImpl.getDisplayClass(
    at jogamp.newt.DisplayImpl.create(
    ... 7 more

Im a bit lost now and would really appreciate it if someone could help! Many thanks!


Sign In or Register to comment.