OSCP5 Multicast

edited December 2016 in Raspberry PI

Hi there!

I'm trying to configure a multicast network with 3 Raspberry pi. The Raspberry are in the same network (I have configured an access point in one of the Raspberry), with IP,,

If I write

// master.pde  (in raspberry                 
oscP5 = new OscP5(this, "", 8975);          

// client.pde  (in raspberry and                     
oscP5 = new OscP5(this, 8975);             
theNetAdress = new NetAddress("", 8975);

It works. In fact, it works incredible well! The sync between the 3 rasp is really good. But, I get the warning - of course - that "" is not a multicast address. I have tried with, etc. and there is no way. It doesn't work.

Any idea?




  • @RaulF I haven't attempted this myself, and my knowledge of "multicast" is rather rudimentary, but: have you attempted to use i.e. the "last" address in the subnet, assuming your netmask is (or /24).

    I believe this is called the "broadcast" address, and might do the trick. (Corrections welcome!)

  • Hi gohai,

    In fact, it works fine when I use "". I receive a warning message ("this address is not multicast", but the sync works. The problem is that when I try to use a correct multicast address, as "" it doesn't sync at all. I have tried several combinations in Master and slave, without success yet.

    Thanks! r.

  • You might want to post this question in a general category, to reach a larger audience (isn't Raspberry Pi specific as far as I can tell).

  • Thanks gohai.

    In fact, I'm almost sure I posted this in Library Questions. maybe I'm wrong.

    Anyway, I have configured a OSCP5 "broadcast" connection that works fine too. I will continue exploring how the "multicast" works, but it's not urgent.

    Thanks again! r.-

Sign In or Register to comment.