Peasy Cam on Processing 2.2.1

edited November 2016 in Using Processing


I am trying to use Processing 2.2.1 instead of Processing 3 and I have to use Peasy Cam. After updating the Peasy Cam, now I cannot use it on Processing 2.2.1 I looked for the older versions of Peasy Cam on Github and tried downloading them. Unfortunately, when I place those older versions both Processing 3 and Processing 2.2.1 won't read the library. I get the error saying a library is missing. Is there a solution to this problem?

Thank you!!


  • edited November 2016

    Processing 3 got the option to choose a different "sketchbook" path, so it doesn't mix up w/ P2 & P1.

  • ah thats cool! I wish I knew it before updating my libraries! :)

    Still, does it make any sense that I download the older releases of PeasyCam and place it in my sketchbook folder but processing 2.2.1 wouldn't see the libraries.

  • Much probably you've updated your shared sketchbook libraries via P3.
    After that, those libraries become incompatible w/ P2! :-&

  • haha yes, exactly. therefore I deleted them and downloaded the older releases of the libraries, like Peasy Cam from Github. I placed them to my sketchbook libraries. Somehow now Processing 2.2.1 and also Processing 3 give the error that the library Peasy Cam is missing. I checked several times if the folders are correct and or if I make any spelling mistakes anywhere of if I copy/paste in a wrong directory but no... :-/ So maybe I am downloading the wrong files? I am downloading the older releases from this link ( are there other links?

  • edited November 2016

    ... and downloaded the older releases of the libraries, ...

    Directly downloading a 3rd-party library for Processing should be the last recourse! :-@

    We should always choose 1st to download from PDE's contribution manager before attempting other methods! *-:)

    Just make sure Processing 3's sketchbook location isn't the same as P2's & P1's. L-)

  • hahah :) thanks. well I am sorry!! But I really tried to download it first through the contribution manager and got the following error.

    java.lang.RuntimeException: java.lang.UnsupportedClassVersionError: peasy/PeasyCam : Unsupported major.minor version 52.0

    and then, now after your suggestion, I placed the p3 sketchbook to the other folder, cleaned all my libraries in p2 and restarted. Downloaded the peasy cam through the contribution manager. I still have the same error. And, really this error is new, happened after I updated the peasy cam in the fisrt place. I did not update or change anything on my Java version :-/

    Sorry to bother you this much, its just annoying that I have spent half day trying to understand what I am doing wrong.

  • I hope you're not confusing things about the installation's folder and the sketchbook's folder! :-SS
    We don't modify the contents within the installation's folder.
    On the other hand, we can choose sketchbook's folder path from preferences menu.

  • hmm no, now I have p2 which has a sketch folder setup as default and p3 and I manually assigned another folder for that. I also have all the other libraries running in both p2 and p3. its just peasy cam is creating this error.

  • edited November 2016 Answer ✓

    If Peasy is the only library not working for P2, you're better off opening an issue on its GitHub: (:|

  • ah ok, well thanks for all the hell :)

Sign In or Register to comment.