launch() doesn't seem to work as described

Note: I'm using Ubuntu 16.04

I have launch() working in Windows, but I'm having issues under Linux.

First I tried: launch("/usr/bin/lame", "/home/name/test.wav", "/home/name/test.mp3"); nothing...

Next I tried: launch("lame", "/home/name/test.wav", "/home/name/test.mp3"); nothing...

According to the reference, one of these should work... "On Linux, it first tries gnome-open, then kde-open, but if neither are available, it sends the command to the shell without any alterations."

Thank you!


  • Um yeah, that happens. No solution so far.

  • @Lord_of_the_Galaxy -- when you open up a new shell on Linux and type for example:

    /usr/bin/lame /home/name/test.wav /home/name/test.mp3

    ... does it work? That is, is this an environment problem, or is it just that the arguments being passed to launch are not correct?

  • @jeremydouglass I've tried a bunch of different shell commands on my (old and fairly useless) Linux system and it works, so I don't see why that won't. Besides, I have no idea which files you're talking about, I did not post the question.
    My comment just signifies that similar problems have occurred with me too. I tried it around the same time when this question was posted, so my processing version was also probably the same.
    BTW I think won't work on some Windows 7 systems also, but that is only what I heard from friends.

  • edited November 2016

    @jeremydouglass Mr. Fry has actually updated the reference to include more information about launch() and exec() since this was posted. I won't mark this as answered since two issues remain.

    -launch() is still not clearly explained under a Linux environment

    -exec() sort of works, but the command kills it self after a few seconds which means it I launch Lame, it encodes part of the file and then quits...

    Also, Processing selects the incorrect sound card on my Mint/Ubuntu system and there's no way that I've found to fix that... but that's an unrelated issue. I just wish Processing was more Linux friendly.

  • @luckyfellow -- When you say "-launch() is still not clearly explained under a Linux environment" -- do you mean that there is more about the reference that you would like to see updates? What are you still hoping to learn (or what have you learned that you would like added to the reference)?

  • @jeremydouglass I suppose you're right. I should open a separate topic for the exec() problem.

Sign In or Register to comment.