processing 3 ide clickable buttons not working

edited July 2016 in Using Processing

I tried installing processing 3 on my computer which is running arch-linux, like everything else i have installed, i have done it from the arch linux packages by in my terminal writing

sudo pacman -S processing

Which did succesfully install processing (x86_64 version 3.1.1-2), which is last updated 2016-06-29

I am able to start processing, write and execute sketches - but all clickable buttons in the ide - except for the big run button seem to be oversized, and completely white, these "buttons" include but are not limited to, the "taps" in the top left of the window, which were supposed to be something like "files" and more, this also effects the popup window which appears when you try to save a file (by pressing ctrl+s), and meens that i can not save.

Here is a picture of me trying to click on a "tap" on the top left of the window; as you see the buttons are clickable, but i have no way of knowing what they does:


(i have obviously tried updating all packages and restarting the computer, but nothing changed)

So it obviously seems like processing is missing some library or tool, to make it work for the desktop environment that i am using (KDE), but every other time i have installed any programs from the archlinux package maneger, it have automaticly included everything that it needs.

So my question is this, why is this happening? does it have anything to do with the way I installed it? and can it be fixed?!

edit: it seems this package i installed is working very fine on someone i knows computer - which is also running archlinux, but not using the desktop environment KDE, which makes me assume, that there is a conflict between KDE and processing. But since it seems that processing can be installed and run fine from the official packages, i don't think installing from the website would make any difference.


Sign In or Register to comment.