Movie playback in Linux Ubuntu 16.04

edited April 2016 in Library Questions

Hello there.

I'm trying to use the movie examples, but I can't get it to work. I had similar problems when using capture, but installing some libraries related and from gstreamer, I managed it to work. The same is not happening in what regards "Movie". I've found some posts in different forums about this same issue and all were pointing to the installation of libraries, which I did, but no luck so far.

I'm running Ubuntu Studio 16.04. I'm not getting any errors, which make difficult to locate what exactly is not working.

I appreciate any directions given, and if somebody out there is having the same problems, say hello and maybe we can try to find a solution together.

best regards, Gil


  • Why there aren't so many questions and no answer at all about this issue? I'm sure I'm not the only one to have it. This means that no one knows the answer or that no one cares? This is sad. In both cases.

    abraços, Gil

  • Hi GoToLoop, thanks for caring. Really.

    Now I'm tending to believe that the case was the "nobody knows" one. =) I have to have a closer look, but I tend to believe that the answer I'm searching for, is not in these links. I was already around most of them and I've found there how to have Capture working. It was about installing some gstreamer libraries. Strangely enough this didn't fixed Movie. I'm thinking about trying some different approach to playback movie. Maybe a sequence of jpegs, I still have no idea about how to - or if I should - do it, but I'll take a look.

    This next is a comment from codeanticode in processing-bugs in 2014. Is still like so? Could be this the source of the problem I'm experiencing? "There are plans to eventually update the video library to use gstreamer 1.x (it currently relies on gstreamer 0.10 which is no longer maintained),..."

    thanks again

    best regards, Gil

  • You're probably still missing some GStreamer 0.10 plugins. Make sure you've got plugins-good, plugins-bad and (possibly) plugins-ugly installed.

    The GStreamer-Java project now has GStreamer 1.x support (I'm the maintainer), so it's just the Processing video library that needs an update now.

    Of course, I should convince you to try out Praxis LIVE instead, where you can already combine GStreamer 1.x and Processing code! :-)

  • Hi neilcsmith_net.

    I'll definitely take a close look as Praxis Live. It looks great!

    I had the good bad and ugly GStreamer 0.10 plugins installed. Although they are not supported in Ubuntu Xenial, which suggested me to remove them because " they are not needed". I'll make another plugins-install party, just to be sure I didn't miss the one that will make things work.


    best regards, Gil

  • Well, movie playback won't work without the plugins for the codecs, which should be in one of those packages. They are needed for GStreamer 0.10, although as soon as that can be ditched for GStreamer 1.x the better!

    If you do try out Praxis LIVE, make sure to switch the GStreamer version from 0.10 to 1.x in Tools / Options / Video or you'll have the same issue.

  • Nice. Good to know. thanks

  • Same problem here, I wasn't able to launch the movie examples. I tried to follow this advice ( ) but the mentioned package is not available in ubuntu 16.04 .

    Anyway, you can add the PPA ( ) to your package list and install it. Here's how :

    sudo add-apt-repository ppa:mc3man/gstffmpeg-keep
    sudo apt-get update
    sudo apt-get install gstreamer0.10-ffmpeg

    It seems to work fine now

  • At first I could only get audio, through jack with no video and no errors in console. After following emoc's post it worked fine, thanks!! (using Ubuntu Studio 16.04)

Sign In or Register to comment.