boolean isPlaying()

edited April 2016 in Library Questions


I probably asked this in the wrong department. I have a sketch written in 1.5.1 which worked and is now not working and I am not sure why it is hanging up on boolean isPlaying(){ return playing; } it is hanging up on 'playing' cannot find anything named playing not sure why......... can anyone help? just downloaded processing 1.5.1 (thought it best to stick to original version) on mac mini running 10.9.4 2.3GHZ Intel Core 17 processor and 4GB 1600MHz DDR3 memory

I can send all the code along if it helps?



  • can you link the class please? It appears that the variable playing is in a separate class and is inaccessible, if your error persists, post back

  • this is the line of code from the declaration at head of sketch (sorry about the language, this was my first and only attempt a coding. I got some help to iron out the bugs. It was working and now is not but I am not sure if it is a hardware or software issue....I have moved the code to different computer)

    OurMovie[] myMovies = new OurMovie[maxmyMovies] ; //declare array of movies

    this is the chunk of code where the sketch gets hung up error message says "cannot find anything named playing"

    /////////////////////////////////// class OurMovie extends Movie {

    OurMovie(PApplet parent, String filename) { super(parent, filename); }

    boolean isPlaying() { return playing; }

    protected void eosEvent() { super.eosEvent(); //println("yeepee"); videoFinished = true;


    it still doesn't work and i am not sure what the problem is......

    any advice greatly appreciated


    p.s. i can send the whole sketch if it would help

Sign In or Register to comment.