Tutorial: Installing Processing 3.x on Ubuntu Linux Computers

edited March 2016 in Share Your Work

I've just added a tutorial to my web site on how to install Processing 3 on computers running Ubuntu Linux.


Feedback as to its clarity and correctness would be appreciated.


  • This worked great! Thank you!

    One correction:

    When creating the processing.desktop file:


    The Icon line should be:


    (it's only /opt/processing/... in the tutorial)

    The tutorial also states that the icon will not stay in the Launcher. For anyone using Docky, it will stay pinned there if you right click and select "Pin to dock".

    Thanks again @jim_plaxco!

  • thank you very much Jim_Plaxco :)

  • holly crap

    I did the full enchilada to install processing, and it ran like a charm ... until I fired up a sketch of mine which requires the video library It told me that it wouldn't run on Processing 64 but on Processing 32 :S

    Nevermind I downloaded right away the 32 bits version... just to figure out I cannot uninstall the Old Processing (because the 3 ways I have tried don't work [synaptic/ubuntu software/apt-get remove])

    So here I am, quite close to the very same point I was back in 1999 when I decided to give red hat a chance and ended up going back to windows 2000

    F@#!k !

  • video library runs fine on my 64-bit box. don't believe the error message. (mint 18)

  • in fact that original post is all about installing on 64-bit ubuntu.

  • You need to install GStreamer 0.10 from the repositories. The video library still does not support the current GStreamer 1.x which is installed by default.

    This is assuming you're running the 16.04 LTS - I think GStreamer 0.10 has been removed from more recent versions.

  • thank you guys !

    so, since I seems to have broken this ubuntu, it is going to be reinstall OS saturday ;)

    I wish I had given up yesterday instead of pushing it

  • edited August 2017

    @neilcsmith_net by doing this ?

    sudo apt-get install libgstreamer0.10-dev libgstreamer-plugins-base0.10-dev

  • edited August 2017

    @phoebus you don't need the -dev packages (they're for compiling), but you will need the good plugins. This should pull in all the other dependencies?

    sudo apt-get install gstreamer0.10-plugins-good

    Unfortunately, 16.04 doesn't seem to have the bad and ugly plugin sets anymore, so supported codecs might be a bit lacking. Keep an eye on https://github.com/processing/processing-video/issues/71 for progress on updating the video library to support GStreamer 1.x

    PS. Or, I convince you to give Praxis LIVE a try, which already supports Processing and GStreamer 1.x :-D

  • hey thank you very much for the help :)

    Praxis LIVE looks very interesting and I might be inclined to use it but for now my point is to have an already made processing sketch to run OK on the Ubuntu machine I got.

    And linux really is the king at showing you that what you were taking for granted in OSs really isn't :S

    I did install GStreamer 0.10 using the command you gave me, and Yes, the sketch runs like a charm. But the videos never showed up :( Instead I see white were I should see my videos So I guess this is the lacking codecs you refer to. Would you suggest that I wait for the video library to show up as "updated" or is there a package I can "sudo apt-get install" ?

    Just as a side note and to refer to the thing you take for granted in OSs, launching a sketch in fullScreen() in Ubuntu let the Top Menu Bar showing :O and "they" say you can (or cannot) remove it , using some more command line trickery. Makes you see things differently after ranting at windows for so many years

    ps: would you say praxis LIVE would be a good choice for some real time graphics running full time ? Working at some retail store animations here

  • But the videos never showed up

    does it work with the video in the examples, transit.mov i think it is?

  • Yes, try some other videos with different codecs. It certainly sounds like it's not got support for the codec you're trying to use, although a little surprised you're seeing white and not black. There is nothing you can install specifically, although I've seen mentions of people installing plugin debs from earlier Ubuntu's on 16.04 - I'd seriously not recommend it! You might find a PPA? The problem is that Processing's Video library is using a version of GStreamer that hasn't been supported for years!

    With regards to fullscreen, what renderer are you using? The OpenGL (P2D / P3D) renderers should be OK with Unity, unless you're using multiple monitors. If you're building stuff specifically for fullscreen presentation (you mention retail store animations?) I'd look at a lightweight Linux desktop like LXDE, Openbox, etc.

    As for the PS, yes Praxis LIVE is good for this - it's close to what I originally built it for. DM me here if you want to talk further on this - keep this on-topic. :-)

  • transit.mov on the loop sample sketch renders black so I guess it is no use to try re-encoding my videos to other codecs ...2

    As for the rendering, I'm running on P3D and, no, the Top Bar doesn't disappear when running fullScreen()... and that is also the reason my videos render White instead of Black (tested on the demo transition.mov video in loop.pde by adding , P3D on size() )

    LXDE look right like what I need but looks like I will need time to switch OS + figure out that I need package xyz to get Processing running + have to wait for the video lib to work on linux etc... could take way more time than having the whole thing working on an old cracked Win7 A shame really, specially when you see how smooth everything goes on raspbian. I think I'm really a client for linux but linux really doesn't want me ;)

  • none of this really belongs on this thread though. it's "Tutorial: Installing Processing 3.x on Ubuntu Linux Computers" not "Linux Video Problems".

  • someone is reporting black screens with video here:


  • just to share the tip, I got it to work by getting the right codecs using those commands

    sudo add-apt-repository ppa:mc3man/gstffmpeg-keep
    sudo apt-get update
    sudo apt-get install gstreamer0.10-ffmpeg

    as suggested here https://askubuntu.com/questions/575869/how-do-i-install-gstreamer0-10-ffmpeg-on-ubuntu-14-10#575888

Sign In or Register to comment.