Code deleted: your sketch has been modified externally

edited March 2016 in Using Processing

Hello all,

just I loosed my work of the day by the following mistake: suddenly a message appears: "your sketch has been modified externally" with Yes/No buttons, but the No button returns the same message and if I push the yes button Code of the last session is deleted e.g. in my case a whole class. Is there a solution of this problem?

Win7 64bit

Help is appreciated. Thanks.



  • What I tried so far is: by renaming the temp file which is saved instead of the original file it is possible to loose only what was done after last save. renaming: name (of original file) + .pde restores the unsaved version of the orignal. see also:

    But this seems still a heavy bug

  • the error occures again and again: different classes have been deleted and I figure out which classes are missing and restore them by renaming. Especially in my situation where I have often to restart the sketch this is really a disaster.

  • Which version of Processing are you using?

  • 3.0.2 Win 64bit

  • until tomorrow morning I hat 3.0.1. After Installation of 3.0.2 I run the sketch with that version and the same errors occured. For safety I just deleted the Installation folder of 3.0.1.

  • I asked because this problem was showing in several alpha release versions of PS3 but I have used both 2.2.1 and 3.0.2 on Osx without experiencing this problem so I don't know what the solution is, sorry :(

  • I use the OSCP5 library from Andreas Schlegel to send Data from Max ( to Processing. Many variables are modified from Max during runtime. I have this problem since changing the code from P2 to P3. Could it be that there is an issue with OSC/ OSCP5? With processing 2 I cannot remember something like that.

  • Many variables are modified from Max during runtime

    I have not used this library but unless it changes the actual source code then you shouldn't have this problem.

  • edited March 2016

    Processing 3 has introduced a new file path for the "sketchbook".
    When 1st installing P3, make sure to specify a path diff. from P2's.
    Lest you end of corrupting installed libraries, modes & tools from both versions!

  • thanks for all your replies! I see. When I start P2 from the icon in the install folder in fact a P3 window is opening. My Sketchpath is even identical because i work at the same project with both versions. So I should probably deinstall P2, the libraries and P3 and reinstall P3 then.

  • edited March 2016

    In PS3 open Preferences from the menu and change the sketch folder so it is different from PS2. Then you can have both versions available.

  • Answer ✓

    i identified my problem: there was a synch feedback between 2 dropbox connected pc. I solved this by manually deselect the synch option for the concerning dropbox folder for one pc.

    thanks for the discussion!

Sign In or Register to comment.