OscP5 not receiving messages. Processing 3.0.2, OS X 10.10.5

Hi, I'm trying to have two way conversation with pure data. I can send messages no problem but processing doesn't seem to be receiving them.

I tried running the oscP5sendReceive sketch from examples and I just get the oscP5 startup messages

[2016/3/14 0:21:36] PROCESS @ OscP5 stopped.

[2016/3/14 0:21:37] PROCESS @ UdpClient.openSocket udp socket initialized.

[2016/3/14 0:21:38] PROCESS @ UdpServer.start() new Unicast DatagramSocket created @ port 12000

[2016/3/14 0:21:38] PROCESS @ UdpServer.run() UdpServer is running @ 12000

[2016/3/14 0:21:38] INFO @ OscP5 is running. you ( are listening @ port 12000

and then nothing. The sketch is definitely looping away fine, I ran it again with a print message in draw() and that gets written out at every call to draw().

Any thoughts? Is this working for anyone else with the same setup?

Thanks, Ciaran



  • Answer ✓

    when you press the mouse inside the sketch window, you should see ### received an osc message. addrpattern: /test typetag: i printed into the console.

    [2016/3/14 0:21:38] INFO @ OscP5 is running. you ( are listening @ port 12000

    Otherwise you can try to change the IP address for the remote location to myRemoteLocation = new NetAddress("",12000);

  • Apologies, late night reading the code, I thought the send message was in draw(). @-)

    This does indeed work and going back over my own code I noticed that I put quotation marks around this

    osc = new OscP5("this", 12000);

    8-| I knew it had to be something simple.

    Thanks for the quick response (and the library!)

    Cheers, C

Sign In or Register to comment.