contribution manager not installing anything in Processing 3

edited October 2015 in Using Processing

I am experiencing an issue with the contribution manager in Processing 3 (OS: Windows 8.1 64bit running in BootCamp on a 2011 MacBook pro): quite simply, nothing would install through it.

More specifically, libraries, modes and tools do not install but the files are downloaded and stored in temporary subfolders within the respective Processing folders (i.e. ControlP5 would download to a temp folder within Libraries but not be installed properly); the error I get in this cases from the Contribution manager says "Error during download and install of ______________." with the name of the library/mode/tool I've tried to install.

Examples, on the other hand, do not show a downloaded file: it seems like they are downloading but when the download bar reaches the end I get this message "Could not find a examples in the downloaded file." and there are no downloaded files in the examples library.

For example, when trying to download the Nature of Code examples through the Contribution Manager I get this: \examples\examples3422910517919542102tmp\natureofcode.DS_Store (Access is denied) at Method) at at at at at at at$ at

I already tried to run Processing 3 in Administrator mode (with the same results); I searched this same forum, the bug database (I've only found this discussion) and through other search engines but I haven't found anything so far to help me even understand the issue.

Thank you in advance for your replies.




  • edited October 2015

    I'm also having trouble with the Library Manager. Apparently, there's no way to redirect the search to local folders, and the library I downloaded (the new, Processing 3.0 compatible version of Syphon) is not recognised after I put it into the Libraries folder. The Library Manager, when I query the available libraries, directs me to an older incompatible version of the same library, so I can't install it, and nothing shows up in the upgrades tab.

    Processing 3.0, running on MacOS Yosemite on MacBook Pro

  • I'm having this same problem. The Contribution Manager doesn't download anything. When I click on Sound and then install, I get this: "Error during download and install of Sound." No other error messages are output as to what the problem is. I get other messages when I try to download them. On SuperCollider, when I install I get "Could not find a library in the downloaded file." I installed it on a network drive here at my school. Win32. Processing 3.3.

Sign In or Register to comment.