UnsatisfiedLinkError: processing.sound.MethClaInterface

edited December 2016 in Library Questions

Hi, I have tried to run examples from sound library v.1.3, but with no success. Processing versions are 2.2.1 & 3.0 betas on linux mint 17 (ubuntu 14.04) with oracle java 8. Error I got:

UnsatisfiedLinkError: processing.sound.MethClaInterface.busConstructMono()I A library relies on native code that's not available. Or only works properly when the sketch is run as a 32-bit application.

I checked a libraries installation directory and everything looks OK - I have all shared libraries on place. I have also set LD_LIBRARY_PATH to include linux64 folder in a library installation directory. Nothing changed. Has someone an idea what is wrong? BTW, is there somewhere good source about using methcla C API? This library looks promising , however it seems that either github page and methc.la lack good documentation.


  • edited December 2016
  • Thanks, however, I checked it with this 3.0a5 you recommended and I got the same error. Did you use a Sound library yourself on linux? What's distribution?

  • edited September 2015

    Sorry, since I'm using a spare laptop right now I haven't re-installed Linux yet.
    Latest version I successfully run in Linux was 2.2.1 under a very old Lubuntu version.

Sign In or Register to comment.