P3D and P2D only working on Processing 2, failing at 3

edited August 2016 in Using Processing

I have tried using P3D and P2D on processing 3, but the sketch window simply doesn't open when i press play. And it doesn't display any errors or messages. But it's working perfectly on Processing 2! What's the problem?

I tried using: Processing 3.0b2 and Processing 3.0b5 both x32 and x64 neither works

Processing 2.2 works

Exported to javascript html canvas also works


  • show a code

    how do you use size()?

    do you have libs?

    did you read the change log?

  • For what it is worth, they work for me, much better than in v.2 where the OpenGL startup was very slow. In v.3, it is smooth / painless.

    In cases such as your, usual advice is to try and update your device driver.

    Note: you don't tell us what is your system...

  • edited September 2015

    It's not specific script, any coode i paste on processing 3, if it has "P3D" or "P2D" including the examples it doesn't work:

    void setup() { size(200,200,P3D); }

    if i use any type of option like P3D, P2D it doesn't run. It also keeps running java on my task manager and i can't terminate it. It only runs sketches that has only:

    void setup() { size(320, 240); }

    My system:

    OS: Windows 8.1/ RAM: 8gb / Processor: Intel core i5 3330 3.00 GHZ / Graphics: Nvidia Geforce GTX 650 (Updated driver) / Audio: Phonic Firefly 302 USB

  • i've gone back to 2.0. 3.0 is too much of a pain....

  • Yeah, i did that too! Until somebody finds out what's going on

  • I have the same issue with Processing 3.1.1 running on 64-bit Windows 7 Pro (the display adapter is an NVIDIA Quadro K2100M and two monitors are connected to the computer).

    Sketches that use P3D or P2D create a process (named along the lines of "jogamp_exe_tst6502892471089317291.exe"), but no display window appears. Pressing the stop button doesn't end the process; it has to be stopped manually using the task manager. Sketches that don't use P3D or P2D mode work as expected.

    For example, the MoveEye example sketch (which uses P3D) has this problem, while the Hue example sketch (which uses neither P3D nor P2D) works fine.

    For the moment, I've switched back to Processing 2.2.1, which doesn't exhibit this issue.

    The problem discussed in this thread ("P3D not always creating window") appears to be related to this issue.

    Is there an existing bug logged for this issue? This bug seems like it might be related, but describes a slightly different problem.

Sign In or Register to comment.