OscP5 not working


Odd problem. I've got only 2 lines in my file:

import netP5.*; import oscP5.*;

On the red bar it says that it cannot parse error text: incorrect classpath

On the black area it states: incorrect classpath ... [loads of java jars]

and later on:

C:\Users\xxx\AppData\Local\Temp\sketch_150823a5093663620607286481temp\sketch_150823a.java:6: error: The import netP5 cannot be resolved C:\Users\xxx\AppData\Local\Temp\sketch_150823a5093663620607286481temp\sketch_150823a.java:7: error: The import oscP5 cannot be resolved

What is going on here?




  • hi, have you tried if the error message occurs when playing a fully working sketch like for example:

    import netP5.*; 
    import oscP5.*;
    OscP5 osc;
    NetAddress addr;
    void setup() {
      osc = new OscP5(this, 12000);
      addr = new NetAddress("", 12000);  
    void draw() {}
    void keyPressed() {
      osc.send(addr, "/test", 1);
    void oscEvent(OscMessage m) {
      println("received ",m);

    which version of Processing are you using? judging by the error message I assume you are on windows? Is the oscP5 library present in the libraries folder?

  • edited August 2015

    Hi and thanks for answering. I forgot to mention that I'm on Windows 10 64, if that matters. I've tested with 64-bit versions Processing 2.0, 2.1, 2.2.1, 3.0b3, 3.0b4. OscP5 is in Sketchbook -> libraries, and 32-bit version 2.2.1, 3.0b4.

    Yes, I have tried a working version. Actually I've had it working a couple of years ago, when I tested communication between Max and Processing.

    Your code gives an error in Processing 3.0b4: The function "send()" expects parameters like: "send(OscPacket, String, int)".


  • the error should go away when using version 2.0.3 of the oscP5 library which you can grab from the github repository here otherwise replacing osc.send(addr, "/test", 1); (line 15) with

    OscMessage m = new OscMessage("/test");

    should do the job.

  • That solved the 'send' problem, but unfortunately not the original.

  • edited August 2015

    Is the library installed properly (yourSketchbook/libraries/oscP5/library/oscP5.jar etc.)? Maybe oscP5 has not been included into the class path by Processing? I can confirm that the example posted above works on osx 10.10 for both processing 2.2.1 and 3.0b5.

  • Seems that I have missed something! I had the Sketchbook in a directory with square brackets in its name i.e. [[MYDIR]], and that was the problem. When I moved the Sketchbook out of it, oscP5 was ok.

    Perhaps it's mentioned somewhere, what the allowed directory names are, but those instructions have totally escaped me. Sorry for the trouble and thanks for your time.

Sign In or Register to comment.