Failed terminating sketch when running from terminal

edited April 2015 in Using Processing

I'm running my exported (as a jar) processing sketch from the terminal. Everything works fine until the very end, but eventually I get this error even though I'm ending my process with System.exit(0) :

X11Util.Display: Shutdown (JVM shutdown: true, open (no close attempt): 1/1, reusable (open, marked uncloseable): 0, pending (open in creation order): 1)
X11Util: Open X11 Display Connections: 1
X11Util: Open[0]: NamedX11Display[:0, 0x7ff8652892d0, refCount 1, unCloseable false]

Furthermore the display window doesn't disappear as well. I looked online but couldn't find any solutions. Does anyone know how can I deal with this?


  • I exported my sketch as a jar file in Windows, and I don't have any problem when I run it from the Command Prompt of Windows. But when I run the same jar on a Linux machine from a terminal I get this error and the display window stays open.

  • As the reference for exit() below explains:

    we shouldn't use System.exit() in Processing! [-X

  • I had the same problem with the exit() as well. It was the first thing that I tried.

Sign In or Register to comment.