Problems running sketch exported to Linux

Hello all,

I'm not very familiar with Linux or running programs via the shell, but following Daniel Shiffman's tutorial series, I wrote a sketch which outputs a PNG and posts it to Twitter. The sketch was exported as a Linux application and runs in headless mode on my server. However, an almost identical method for another sketch doesn't seem to run at all and I'm not sure where the problem lies.

When inspecting the files in Linux, my terminal colour codes one of the exported applications green (meaning an executable), but the non-functional one is coloured white (i.e. not recognised). This probably isn't a reliable means to debug, but could there be something in my sketch which is preventing it from exporting properly?

I've tried troubleshooting using the Wiki, but can't see anything which might be causing it. If anyone has experienced anything similar (or can see something glaring which I'm overlooking), I'd really appreciate some advice.

Full sketch code can be found here:



  • I'm having a similar issue. Hope someone can chime in :)

  • Answer ✓

    ls -l will show you the executable status of the file, try that. relying on the colour alone is a bit dangerous, especially given that not all terminals are capable of displaying colour.

    you can change the executable status of the file using chmod +x filename

    you can check what kind of file it thinks the file is using file filename

  • why is it obitbot in the pictures but tombstone in github?

  • I actually resolved the issue last weekend and forgot to update this thread. Fairly embarrassingly, the only issue was that I hadn't set the permissions properly. A simple chmod 777 filename solved everything (as you touched upon @koogs; thank you).

    The screenshots are from an older test branch. The sketch names are different but unrelated to the issue at hand.

Sign In or Register to comment.