ProControll / Game Control Plus Export doesn't work

I have game project that used Procontroll lib on Processing 2.2.1 and wich works fine in the editor but when i try to export the application it just doesn't work. When i double click the exe nothing happen or i just get a sketch with a gray background ... So i tried to export one of the exemples from ProControll and it did the same thing. Knowing that the autor stop working on it i found Game Control Plus who unfortunatly doesn't work either (the exact same problem). Am i doing something wrong ? or is it just my setup ?

I use Win10 x64, and Processing 2.1.1.

I did try to update the jinput dlls and all but same result.

Help ?


  • edited October 2015

    Can't speak for proControll but I have just tested Game Control Plus on my machine (Mac OSX) and the exported application works just fine.

    If it works in the PDE and not the exported application then it is not your setup. Make sure any files your application needs are in a folder called data inside the sketch folder before exporting.

  • Well i know that but i tried it with the exemples from your lib (i believe you're the autor of Game Control plus, right ?) And even their it doesn't work ...

    I can't find why...

    Is there a way to see if the .exe send any error message like a log or something like that ?

  • I don't know why either. As I said the examples worked for me. There is no error log and if your sketch works in the PDE it should work when exported.

    Sorry not sure what the problem could be, unless you are trying the exported app on a different machine or you have different devices attached. Note that the input device must be connected before running the sketch.

  • No i'm trying it on the same machine and with the same devices ... Also a friend of mine tried it (the example) and it doesn't work either ...

    Is this a bug with Processing export with libs on Windows ?

  • edited October 2015

    Do you know someone who can try it on a Mac?

    Edit: forget that, it won't prove anything. :(

  • Do you know someone who managed to make it work on Windows ?

  • I don't get to hear when someone is successful using my libraries because people only come here with problems.

  • edited October 2015 Answer ✓

    I figured it out, FINNALY: jinput-dx8_64.dll needs to be next to the exe not in the lib folder (Cheers to Procmon !).

    There you go and considering the number of people who got this issue i think its safe to say that they should either move the dlls from the lib folder to root of the app or add durrentDirectory/lib to the search path when launching processing.

    Or at least make it clear somewhere that when a lib doesn't work it is just because of that ...

    Anyway thank you so much for your help, i'm gonna try and return the favor by helping the follows here.

Sign In or Register to comment.