trying to set the font, getting a black screen instead

hello, i'm trying to code a short interactive animation in openprocessing with images, sound, and text, and when i try to use textFont() in preload(), my whole sketch goes black (though the interactivity and sound both remain). and if i try to use it in draw() or setup(), it sets itself to a different font instead and sets the font size to the same size across the sketch.

the only time it has worked when i tried (but not with the typeface i need) it is when i set it to textFont('Courier') in draw(). i've tried to load another .ttf file to see if the font itself was the problem, but the replacement one didn't work either. the font i'm trying to load is this one.

you can find my sketch here. it takes a little bit of time to load. i would post the code here, too but there are a dozen files needed to play it locally, so i think it's better if i don't. if you need more information, let me know.

thanks in advance.

Sign In or Register to comment.