grouchy OpenCV on MacOS X and Ubuntu

edited November 2014 in Library Questions

Hi! I recently started to work with Processing librairies. After I had downloaded almost each library that Processing suggested to me in a little useless way, when I tried to trigger the only that is really important for my project, it didn't work. Kind of upsetting, no?

Ok, there is the matter: Processing can't find the OpenCV library when I start the sketches, yet they are into the libraries folder. Of course, I have an (or even several! :) ) error messages. It seems to has "Something" to do with 32-bit mode, like if it could execute properly only in 32bit. That's annoying because i'm working on Mac OS 10.7.5, with Processing 2.2.1. Java is running in 64bit. I tried, like I saw in posts of the previous forum, to make it run in 32bit via the Terminal, but it didn't work.

[opencv fatal error] library not loaded !
Verify that you are running in 32-bit mode, the opencv.framework exists in '/Library/Frameworks' folder and the java.library.path property is correctly.

error message: /Users/Upermuk/Documents/Processing/libraries/OpenCV/library/libOpenCV.jnilib: dlopen(/Users/Upermuk/Documents/Processing/libraries/OpenCV/library/libOpenCV.jnilib, 1): no suitable image found.  Did find:
    /Users/Upermuk/Documents/Processing/libraries/OpenCV/library/libOpenCV.jnilib: no matching architecture in universal wrapper

A library relies on native code that's not available.
Or only works properly when the sketch is run as a 32-bit  application.

I have the same problem on Ubuntu 14.04 64bits. Please believe I checked the ubaa installation up and made many researches. Of course, I can be a little blind, but it sounds kinda fatalist.

I would be happy with your help !

Sign In or Register to comment.