Processing Applet blocked by Java !

I have installed AppletMaker by Peter Lager to export my Porcessing code in JavaScript and HTML format. When I try to open the HTML file using any web browser, the applet is blocked by Java. Here is the error I receive:

Error 1 Error 3 Error 2

I am using Processing 2.0, Java plug in 8 and JDK 8. I created a custom webpage and added the applet on the page, then loaded it on IIS but still can't load the applet and receive the same error message. I have also tried to run it on two different machines. Some suggested to put the Java security level to medium but that option doesn't exists in the new version of Java.

Now my question is how to solve this problem and how to make sure I can have my processing program as a JavaScript applet running on a web page without this sort of problem?


  • This is a local Java setting that's preventing your sketch from running, but there is nothing to do on your end to make sure it works for others (except maybe signing your sketch, which is a hassle).

    You need to open up the Java Control Panel, click the Security tab, and add your page as an exception in the Exception Site List.

  • @TfGuy44

    (except maybe signing your sketch, which is a hassle)

    Actually that's not the case, AppletMaker provides a simple option to sign the applet and in fact Persis has done this because the message was

    Your security settings have blocked a self-signed applet from running.


    (1) An applet is a 'java program in a webpage', there is no such thing as a JavaScript applet

    (2) Although AppletMaker can sign the applet this is ONLY necessary if the applet is required to access the local machine e.g. access the hard drive. If the applet doesn't have to do this then don't sign it - it only makes the client machine more security conscious.

    (3) Try different browsers e.g. FireFox

    (4) Try TfGuy44's suggestion re Java Control Panel

  • @TfGys44, @quark - Thanks for the suggestions

    My app does not need to access anything from the local machine. Also, I have played around with Java Control Panel. The problem is with version 7 and onwards, they have removed the medium security option and I believe that is what I need in order to run my applet. Also, I have added my webpage address(http://localhost:81) to the list of allowed sites in Java control panel but my apples is still blocked.

  • Have you tried uploading the webpage and applet to a web-server and view it from there, rather than as a local file?

  • well I am running IIS and hosting my website on it all on the same machine. before I was just trying to open the HTML file in a browser, then I did the hosting but that didn't solve anything

Sign In or Register to comment.