can not see "Android" in "Add Mode"

edited September 2014 in Questions about Modes

Dear all,

I am totally new with Processing, but a little familiar with programming. I try to start with the very first example of the book Rapid Androit Development P2.0 on page 6 of chapter 1. So far after installing a lot of packages from internet, I can not see the Mode Android in the pull down menue. I have downloaded and installed mode "Java Script", which means, I understand how to add an mode.

Anyyone here to tell me how I can add the Android mode? May I make a search for any files on my harddisk? Are there any variables to be set in the environment on WinXP32bit (prof)?




  • Um, have you looked in the Mode Manager (Click the currently set language, then press "Add mode")? Android mode is quite literally the first mode that is available.

    Because from what I'm seeing, is that you're are downloading these packages externally. So now try to install a mode within Processing.

  • Oh. Let me eat my words, now. I don't see it, either.

  • edited September 2014 Answer ✓

    However, I have noticed that happen after I attempted to install Android mode, which resulted in an error saying something along the lines of "No mode available."

    Have you encountered some form of error prior to Android mode disappearing?

  • edited September 2014 Answer ✓

    Well, I have to say that the same happened to me, at Windows, too. But for me, it was only Android mode which disappeared. I've tried deleting the previous folders, unsuccessfully. If I have any new, I'll say about it over here :/

  • Dear all,

    any idea, we can contact? I is a pitty, the explanation in the book differs compared to the real world, which spins much faster than the print roll turns. This starts with the download process of SDK and so on ...

    I would appreciate any response from a Win XP user, how he installed his SW packages.

    BR Bernd

  • Hi I continue here the discussion open in "Where is the "Android Mode?" topic. The problem is the same. Where is the Android Mode? It is not present in the modes list. I installed the 2.2.1 version for the first time. I use windows 7 and I work with processing usually, but never with the Android mode.

  • I have the same problem. I have installed with jdk and android sdk, but I can not find the android option in mode manager of processing. My system is windows 8.1, 64 bit. No clue/solution yet....

  • Dear Folks,

    after several days of browsing in internet I got it fixed for the first steps ...

    Pls feel free to read the attached PDF-file how I "installed" it. As I understand, Sketch-editor checks for data in subdirectories and enables the dropdown menue.

    Meanwhile I am fighting with the emulator and hardware to start with my very first example (page 14 in textbook). I am a little bit disappointed that so many links in internet are broken and so many software packages are different to what they should be and described in the textbook.

    I hope, my little contribution will help a bit.

    BR Bernd

    PS: GRRR I am searching the function to attach files to my comment.

  • edited September 2014

    so no pdf, here are the JPGs:







    It seems to me, the tools in this forum are not very hostile, JPGs consume much more time to produce ...

    Have fun


  • Worked perfectly. Just to let you know!

    Thanks anyway ;)

  • ... have fun


  • It works also for me. Thanks a lot!!

  • thanks alot bro :) worked!!!

  • It did not work for me on Windows 7 (64 bit). When I activate the dropdown menu there is no selection called Android. When I click Add Mode... there are several choices but Android is not listed.

  • edited September 2014

    Did you extract the AndroidMode folder to your Documents and settings-folder or the program folder? Because that's what I did at first. It did work when extracted to "C:\Users\-my username-\Documents\Processing\modes".

  • I am using Processing 2.2.1 I have followed the instructions by Bernd to add "Android Mode" However when I start Processing and click on the mode TAB, only the Java mode is available. I need to install "Android Mode" on a PC that has not an internet connection. Any solution? Thanks.

  • Followed Bernd's instructions on Ubuntu 15.04 Beta 2 but the only options in the list for me are still Java and JavaScript (installed it to see if the whole thing was messed up or not). I am using 64-bit Processing 2.2.1 and copied the AndroidMode folder to the 'modes' directory in where I have Processing installed and also created a modes directory in home/username/.processing. Not sure why it's still not working for me... or William for that matter. There is no 'Documents and Settings' folder on Linux... but I thought that got phased out in Windows XP anyway?

Sign In or Register to comment.