Java Mode not working ,JavaScript mode working (Linux)

Hi I have worked before with processing without problems, however now i just did a clean installation of my Linux box and im having a hard time making it work...

I just installed processing (2.2.1) and when trying to run a sketch in Java mode nothing happends and there is no such thing as an error or output from the terminal.. I tested javaScript mode and that one does work..

I tested and downloaded the old 1.5.1 version and in there Java mode works fine...

Any ideas??...




  • Answer ✓

    I'm on Lubuntu. But I'm still using Processing 2.0.2. Perhaps you should try 2.0.3! :|

  • Same thing with 2.0.3.. no luck :s

  • Delete/rename "/java" subfolder! That'll force Processing to use system's default Java! :-\"

  • Already tried that and still the same problem, also i have tested with both OpenJDk and Oracle's with the same problem..

  • I just figure it out :), seems like if your /etc/hosts file specifies a hostname different to localhost it wont work...


  • Never seen a Linux OS w/o localhost on it! ~:>

  • edited July 2014

    i had an error on the file instead of localhost.localdomain localhost mylocalhost

    i had localhost.localdomain mylocalhost

Sign In or Register to comment.