Raspberry Pi and Processing problem with camera capture

I installed Processing 2.2.1 (linux) on the RasPi (running Debian Wheezy) to connect a USB-Webcam and capture video stream with the standart processing.video* library. When I try to run the program (from processing window or exported) I get the following error:

NoClassDefFoundError: Could not initialize class com.sun.jna.Native

After searching the web for several days I found and tried following solutions, wich did not change anything:

· Install gStreamer 0.10 package (as seen here)

· Update to the latest Java Version which is: java version "1.8.0-ea" Java(TM) SE Runtime Environment (build 1.8.0-ea-b108) Java HotSpot(TM) Client VM (build 25.0-b50, mixed mode)

· Install JNA 4.0.0 (reference here)

after it still resulting in the same error, I am not really shure what to try next since I am also more or less a beginner when it comes to the RaspberryPi and Java.

Any Tips / Hints are highly appreciated!

Sign In or Register to comment.