Processing 2.2.1 64bit/32bit + eclipse - video problems


I am trying to run a simple playback example via eclipse.

I managed to run it through the PDE (64bit). (after throwing into the jre/bin/ext folder)

In eclipse however, it does not work.

First I point to the QTJNative.dll
(I am not sure whether this should be a native for the video.jar in my reference libraries or for the in my system libraries...)

either way the compiler does find it... but then says it cannot run a 32bit AI on a 64 bit platform...

How did it work inside my 64 bit PDE then? How to fix it in eclipse?

Thank you so much for any help!!!

***pushed this to hardware integration.


  • ...still trying... - update:

    I tried switching to a jre7-32 bit.

    What I did was: - changed to jre7-32 as the default vm inside eclipse (WIndow>Preferences) - changed the processing reference library to the 2.2.1 32 bit version - got a no jogl in library path error - procured a jogl.dll from the opengl processing library folder (the i586 windows natives jar inside processing had some dlls but not that one - I threw those into the project natives directory anyway) - got an out of memory error (at a BlobDetection part of my code - that part run fine in the 64 bit before) - added an argument to Run Configurations to increase the memory buffer(?) - the compiler then reminded me that I did not put the into the 32 bit java installation (bin/ext); Which I then did.

    Finally, I got

    quicktime.std.StdQTException[QTJava:7.6.0g],-108=memFullErr,QT.vers:7758000 at quicktime.std.StdQTException.checkError(

    ... so I think same memory problem but now with all libraries properly located?

    in fact a similar thing happens in Processing 2.2.1 32 bit itself. A movie playback example (that I run with the 64 bit version alright) has a memory problem.


    [0] "Error occurred during initialization of VM" [1] "Could not reserve enough space for object heap" "

    The 'increase maximum memory' setting setting in preferences is set to 3000MB

    Thank you for any help!

  • SUCCESS !!!

    an update for whomever may be in a similar situation:

    1. Processing 2.2.1 32 bit did run the movie playback example after disabling the "increase maximum memory" setting in preferences. I read somewhere that Windows memory limit on 32bit processes is around 1200MB... that is what might have been blocking it.

    1.1 Eclipse configured in accordance with the 32 bit logic did play the movie - but I ended up having "out of memory" exceptions when running my entire code so I preferred getting the 64 bit version running.

    1. Processing 2.2.1 64 bit did run the movie example. Indeed it seems like all of its resources are packed in the processing installation folder. ALL ! - including the Java, and the video library... everything. I restructured my build path in eclipse only to resources from that folder - AND IT WORKED!
Sign In or Register to comment.