run Kinect in macOS 10.9

edited March 2014 in Kinect

Hallo, I'm trying to run the SimpleOpenNI examples for Kinect using Processing 2.1.1 but it don't work. I recibe this message:

SimpleOpenNI Version 1.96 send_cmd: Data buffer is 322 bytes long, but got 334 bytes freenect_fetch_zero_plane_info: send_cmd read 334 bytes (expected 322) freenect_camera_init(): Failed to fetch zero plane info for device libc++abi.dylib: terminating with uncaught exception of type std::runtime_error: Cannot open Kinect After initialization:

I have already worked with this Kinect in an other macOS 10.6, using Processing 1.5.1 and SimpleOpenNI Version 0.27 Do somebody have an idea, how to solve this problem? thank you! mariana


  • I have found that there are diferent Kinect models, and the Kinect for Xbox 360 Model 1473 should have a few problems reported and more or less solved here:

    ....... but I don't understand how to apply it in Processing 2 !!??? could somebody help me???

    What ever, I think that also the "right" Kinect model #1414 has problems to run in macOS 10.9 (mavericks) ... so I have two problems :(

    Possible, this lik can be helpfull:

    thanks mariana

  • Have you got it to work? I can only make it work on older processing. not the latest. I am going to give it another try and move on to openframeworks C++ as I think I know how to make the kinect work with it using pure data . It SHOULDN'T matter, but unfortunately, nothing is working in terms of kinect :(

Sign In or Register to comment.