Unable to read serial port on windows 7

I've got an application which I wrote on a Mac but need to run it on windows, I exported it, it said it cannot export in x64 so I just exported x32 and transferred it onto the mac mini with windows 7 HE installed.

The app needs to access via USB a webcam and an Arduino Uno. I first installed the FTDI driver, Quicktime and Java x32 version onto the pc. The app opened successfully but it was unable to access any of the serial ports. I tried installing Processing onto the computer and println the Serial.list() but still nothing showed.

Is there supposed to be some sort of driver that I'm missing? I have no idea what did I do wrong.


  • I checked the device manager, the computer recognizes the webcam as Logitech and stated that the driver is installed, the Arduino Uno on the other hand, said its still missing a driver.

    I do remember a couple years back it would just say COM1, COM2 but I don't see it now. It has been a long time since I've touched a PC.

  • Answer ✓

    You are missing the Aduino driver, i wonder if you read the arduino start up manual. Here's what you need to do arduino.cc/en/guide/windows#toc4

  • Thanks

    About the webcam, it seems that its because the capture library was broken in the 2.1.1 release so i just had to replace the 2.1 library into the 2.1.1.

    I installed the arduino driver, it now recognizes it as COM3, but now processing keeps telling me that the port is busy when I run the app. I tried changing the port to COM2, COM9, COM8 it still doesn't work.

  • It worked. Actually it was another issue that was causing the problem. Since I used an external file to load the port name in, it so happened that the problem was loading the text into processing. The usual loadStrings would insert itself into an array in sequence, in windows it actually skips an extra index every time it switches to the next line, causing the program to use an empty string as a port name. I didn't think that an empty port name would actually return a "port busy" message, a bit misleading imo.

Sign In or Register to comment.