Eclipse PApplet problem

I was testing some java code made in Processing and exported to Eclipse:

import processing.core.*; 
import ddf.minim.*; 

public class processingTest extends PApplet {

AudioPlayer song;

Minim minim;

public void setup() {
  size(560, 320);

  minim = new Minim(this);
  song = minim.loadFile("song.wav", 2048);


public void draw() {
  stroke(random(255), random(255), random(255));
  fill(random(255), random(255), random(255));
  rect(random(width), random(height), random(width/2), random(height/2));

public void stop() {

  static public void main(String[] passedArgs) {
    String[] appletArgs = new String[] { "processingTest" };
    if (passedArgs != null) {
      PApplet.main(concat(appletArgs, passedArgs));
    } else {

I had this problem when trying to run the exported code in Eclipse:

PApplet [java application] Usage: PApplet For additional options, see the Javadoc for PApplet

Any suggestions?


  • ehh fixed it soz :P I bet you guys to it.

  • Answer ✓

    So you fixed it - but you asked for help and expected an answer, so why not help others who might experience the same / similar problem by telling us the solution????

  • edited March 2014

    Sure. What I did for others that might have had my problem:

    1. Right click the project -> preferences -> Java build path -> Libraries tab. You can add the library there with "add a jar".

    2. The problem was the processing libraries are hidden on the mac (I didn't know that) Find the processing libraries by going Go -> Go to folder and go to your hidden library folder that way

    3. Right click on the imported jar -> use with java build path (I think it was)

    Done ^_^

Sign In or Register to comment.