Can't get Processing to see the SDK

edited December 2017 in Android Mode

OS: Windows 10 64bit Every time I'm trying to switch to Android mode, I get this:

"Download SDK automatically" starts downloading, then at ~250MB the window suddenly dissapears and I get this:

Tried it about 5 or 6 times already.

And when I try to locate path manually after installing the thing from the link from the first message box, simply put, no folder works. I installed full Android Studio, went into settings, and in SDK Manager I downloaded SDK Platform "Android 8.0 Oreo" (SDK Level 26 because the popup wants that and not the 27)(neither 26 or 27 give any results): I noticed it downloaded it into SDK installation folder/platforms/android-26: I tried targeting this folder, aswell as any folders above or inside this one, none of them do a thing. I guess this also has something to do with the fact that practily every single Processing Android mode tutorial I could find has different SDK Manager and Android Studio GUI, aswell as that Processing asks for Android 26 SDK while 27 is the latest.

(sorry for the excessive image use, I just like documenting things as detailed as possible)


  • edited December 2017 Answer ✓

    Nevermind, just fixed it by randomly mashing buttons and doing things. I think what solved my issue is a little guide that this person made when they got the same error: (look at the second post in this thread)

    Also, here are random tips that helped me: * Once, when choosing a folder, it gave a Java error into Processing window's console view thing below, that basicly said that it was unable to find folder "tools" in the folder that I chose.

    • When installing "Android Studio", after that it will ask where to install the SDK Tools(I chose C:/Games/Android/SDKThing), and after it's done with that, the folder inside of it will have a folder called "tools"(exactly same folder that is in the "Command line tools" download)

    • I pressed WIN+R, typed in cmd(to open Windows command prompt), then I did "cd C:/Games/Android/SDKThing/tools/bin"(to change directory to the folder with a bunch of .bat scripts inside of it), then I ran every command in that other person's solution.

    • Then I chose the "C:/Games/Android/SDKThing" and suddenly it works.

    Posting this as it might help someone.

    EDIT: Just found out that if your Android device is, for example, running 4.4.2, then for this you need Android 19 SDK, and 26 SDK doesn't do the trick, making Processing "waiting for device to become available" forever. Installing Android 19 SDK along with other SDK's makes it do the thing.

  • edited March 4

    @Architector_4 Thank you for sharing your solution.

    ****EDIT: A guide to installing SKD manually (from a quick Google search):


    Keyword: Android_sdk download_sdk locate_sdk sdk_tools android_tools kf_keyword

  • Ohyes, right, I forgot to write down some tags. Thanks for reminding!

  • edited January 15


    I ran in the same issue installing processing on my new PC. OS: Windows 10 64bits Processing: 3.3.6 I tried your solution but an error appears when I type the sdkmanager command

    C:\Users\ADMIN\AppData\Local\Android\Sdk\tools\bin>sdkmanager "build-tools;26.0.0"
    Exception in thread "main" java.lang.NoClassDefFoundError: javax/xml/bind/annotation/XmlSchema
    Caused by: java.lang.ClassNotFoundException: javax.xml.bind.annotation.XmlSchema
            at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(Unknown Source)
            at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(Unknown Source)
            at java.base/java.lang.ClassLoader.loadClass(Unknown Source)
            ... 5 more

    I've installed jdk-9.0.1

    When asked by Processing,I specified the SDK folder manually to C:\Users\ADMIN\AppData\Local\Android\Sdk

    The script starts compiling but I end up with this error

    1. ERROR in C:\Users\ADMIN\AppData\Local\Temp\android7555099663370003499sketch\app\src\main\java\processing\test\ac_controller\ (at line 321)
        startActivityForResult(enableBtIntent, REQUEST_ENABLE_BT);
    The method startActivityForResult(Intent, int) is undefined for the type ac_controller
    1 problem (1 error)
    FAILURE: Build failed with an exception.
    * Where:
    Build file 'C:\Users\ADMIN\AppData\Local\Temp\android7555099663370003499sketch\app\build.gradle' line: 62
    * What went wrong:
    Execution failed for task ':app:compileDebugJavaWithJavac'.
    > Process 'command 'D:\Formation\Processing\processing-3.3.6\java\bin\java.exe'' finished with non-zero exit value -1

    Any idea on what I'm missing.

    Thanks in advance

  • @Xukyo uhh... I have no idea. My issue was that Processing could not locate the SDK and would always complain, yours seems to be about it not being able to read something needed in SDK, and I have no idea how to help with that... Try creating a new topic and asking there!

Sign In or Register to comment.