Can't find GifAnimation library.

Hi there.

When I determined that GIFs would be nice to generate I discovered the GifAnimation library. I downloaded the port of it for Processing v3 (discussed here: https://forum.processing.org/two/discussion/12737/gifanimation-for-processing-v3.)

I followed the instructions to put the GifAnimation folder in my processing libraries folder, but processing can't find it. ("The import gifAnimation cannot be resolve.") I believe it's in the right folder: Processing/libraries/GifAnimation. It finds other libraries there, but not this one.

Would appreciate any insights about how to get it working. Does it need to be registered somehow? I'm completely at a loss.

Thank you in advance for any help.

Answers

  • No it doesn't need to be registered. I used this library a while ago so couldn't remember it clearly but, remember I had a problem like this too. What the error says? Have you tried putting it manually?

  • edited October 9

    Thank you for the reply.

    The error is: "The import gifAnimation cannot be resolved."

    Not sure what you mean by "have you tried putting it manually." The import cmd is: import gifAnimation.*;

  • edited October 11

    Hi kfrajer, thank you for the reply and link, which I had come across earlier.

    Everything looked correct. But I must have read it more carefully this time, because I came upon this sentence: "After a library has been successfully installed, restart Processing application." D'OH!

    Of course, that makes complete sense... now... and I am quite red-faced at the moment...

Sign In or Register to comment.