Building Processing sketches in Sublime 3 in Arch Linux?

edited August 2017 in Using Processing

(Sorry if this question is in the wrong category)

I followed the steps to install and use processing-sublime in Linux, but so far I haven't been able to build a sketch from Sublime, I get the following output:

Picked up _JAVA_OPTIONS: -Dawt.useSystemAAFontSettings=gasp
Could not create the output folder.
[Finished in 0.2s with exit code 1]
[cmd: ['processing-java', '--force', '--sketch=/usr/share/processing/modes/java/examples/Basics/Color/Hue', '--output=/usr/share/processing/modes/java/examples/Basics/Color/Hue/build-tmp', '--run']]
[dir: /usr/share/processing/modes/java/examples/Basics/Color/Hue]
[path: /usr/sbin:/sbin:/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/usr/bin:/usr/lib/jvm/default/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl:/usr/share/processing/processing-java]

I installed the latest Processing from AUR and added processing-java into the PATH in my ~/.profile file.

Sketches run fine otherwise in Processing.

Thank in advance



  • edited August 2017


    there's the output directory. does it exist? do you have write permission?

  • ls -ld /usr/share/processing/modes/java/examples/Basics/Color/Hue/build-tmp

  • edited August 2017

    This happened when trying to run one of the examples. I just tried with a sketch where I have file permissions and worked just fine.

Sign In or Register to comment.