Trouble with adb after installation

Hello everyone,

I'm using processing on ubuntu for almost one year now and I'd like to export my sketches for android. So I tried to install the android mode, which asked me to install the android sdk. I had the choice to locate the sdk on my computer on to let processing download the sdk itself, which I chose.

The download went great and after it a window named "Trouble with adb!" popped to say me this : "Could not run the adb tool from the android SDK. One possibility is that it's executable permission is not properly set. You can try setting this permission manually, or re-installing the SDK. The mode will be disabled until this problem is fixed."

I already tried to re-install the sdk and it didn't changed anything. I also searched on internet if a could find something to do with this but i didn't found something helpful.

I'm currently running on ubuntu 16.04 LTS and using processing-3.3

If someone can say me what to do or say me where to look i would be really thankful.

Best regards, Gaeth



  • Did you follow the instructions it gave you?

  • Well i don't know on what folder i have to change permission

  • Check the output, it might tell you where adb is.

    Alternatively you can use which or updatedb / locate to find files.

    You must have some idea where the SDK is...

Sign In or Register to comment.