VR sketch not working on Daydream View

edited July 12 in Android Mode

The Introduction to VR page says VR sketches should run on both the Cardboard and the Daydream View. I have the latter, but I fail to deploy even the simplest of demos [1]. The app crashes and I get the following error:

Incompatible app This Cardboard application is not compatible with Daydream headsets.

I'm using the Google Pixel, Processing 3.3.5, AndroidMode 4.0-beta9, and have both the Daydream and Cardboard apps installed on the phone. Furthermore, I'm deploying the app using the SDK Tools v25.2.5; the SDK Platform-tools v25.0.6; and the SDK Platform v25 (rev. 3).

Can someone confirm that the Daydream actually works?

[1] Code:

import processing.vr.*;

void setup() {
  fullScreen(STEREO);
}

void draw() {
}

Answers

  • Tagging @codeanticode and also @alayna. @alayna, feel free to help if you wish. An additional note: having your code in DayDream could impact the number of users that could use your demo.

    Kf

  • Thank you for the tags @kfrajer. I've updated my question to include the Android SDK version.

  • Possibly relevant previous discussions: daydream

  • Unfortunately I can't confirm that Daydream works since I don't have the headset or the right phone. Good luck, I hope that it ends up working for you!

  • Thxs nyways @alayna . You are right, nothing much can be done without the handset :-B

    @AugustoEst Quick question: Is there any permissions required to set to operate VRs?

    On a side note, I did a Google search on "This Cardboard application is not compatible with Daydream headsets" and I got few hints. Here below is one. Not sure if it applies:
    https://stackoverflow.com/questions/40731800/incompatible-app-error-with-google-vr-app

    I hope this helps.

    Kf

  • edited July 12

    Some updates on this issue:

    1. I've tried AndroidMode betas 8 and 7, with the same results

    2. I've changed the Android Manifest from

    android:name="com.google.intent.category.CARDBOARD"

    to

    android:name="com.google.intent.category.DAYDREAM"

    I now get to the screen below, but the Processing sketch crashes before I can do anything. Afterwards it goes to the following picture (pressing the Home button seems to try to run the sketch, but it's followed by another app crash).

    screen

    screen2

    3. I've disabled the Google VR Services, which gets me the following error message when I start the sketch:

    Update Google VR settings Daydream won't run unless you make changes to Google VR settings.

    (thank you for the link @kfrajer)

    4. I've included the NFC permission, as the phone uses it to pair with the Daydream View - same results

    Any other ideas?

  • Answer ✓

    I've solved the problem by manually editing the AndroidManifest.xml, and adding:

    <category android:name="com.google.intent.category.DAYDREAM"/>
    <uses-permission android:name="android.permission.READ_EXTERNAL_STORAGE"/>
    

    There's no way to do the first line in the Processing GUI. Adding the permission through the GUI does not save it in the manifest for some reason.

    Now I can just launch the Daydream app and select the Processing sketch as any other app.

  • @AugustoEst -- thank you for sharing your solution!

  • @AugustoEst Just came across this post. Thanks for posting your solution! I don't think it would be possible to set the Daydream mode through the GUI, unless adding a new menu option to select between Daydream and Cardboard, but I will open an issue about this.

Sign In or Register to comment.