Processing 2.1 on Raspberry Pi: installation and serial support

With hardfloat Java on Raspberry Pi, Processing runs quite quickly. I've developed and tested an installation procedure for Processing 2.1 on Raspbian: Processing 2.1 + Oracle Java + Raspberry Pi + Serial + Arduino = ☺

(the hard part was working out that I needed to replace Processing's cut-down jssc.jar with the stock one, which includes armhf drivers.)

I haven't been able to do anything about the graphics and video issues other people are having. Firmata integration is more important to me.

cheers, Stewart


  • I have tried to install processing on my raspberry. The installation did not mention anything, but when I started processing I got an error:

    /home/pi/processing-2.1/java/bin/java: 1: /home/pi/processing-2.1/java/bin/java: ELF04?: not found /home/pi/processing-2.1/java/bin/java: 2: /home/pi/processing-2.1/java/bin/java: Syntax error: "(" unexpected

    Can you tell me exactly how you got processing installed on your raspberry. I am good informed about linux, but it is not enough to the very depth! Eg. I do not know what "Processing's cut-down jssc.jar with the stock one" means. I know that I need arm drivers, but where I could get them ????

    I would like to connect my raspberry with up till now three arduinos, who are controlling several things, like traffic lights, photo sensors and servo motors, on my model railway emplacement.

  • Thanks, I did not see the link! Sorry, but it is rather slow and I think for my project it is not suitable.

  • edited September 2014

    guys. I have the same problem .. vdhart

    ~/Desktop/processing-2.2.1$ /home/ubuntu/Desktop/processing-2.2.1/jav a/bin/java: 1: /home/ubuntu/Desktop/processing-2.2.1/java/bin/java: ELF04°: not found /home/ubuntu/Desktop/processing-2.2.1/java/bin/java: 2: /home/ubuntu/Desktop/pro cessing-2.2.1/java/bin/java: Syntax error: "(" unexpected

    I would like to know how you solved the problem?

Sign In or Register to comment.