Emulator simply won't run.

Whenever I try and run an Android script in the emulator, the console pops up with the error: android.util.AndroidException: Can't connect to activity manager; is the system running? I've looked around and tried solutions, such as deleting the AVD processing created and creating a new one, manually starting up the emulator, updating the SDK, but so far nothing has worked. I am using Processing 3 on Windows 10 with the latest version of SDK.


  • The emulator takes a long time to boot up. Wait a full 24 hours before giving up.

  • Here are my tips: Use a real android phone if you have access, it's much much faster - and more likely to actually work.

    Use a good usb cable. Keep notes while you get it set up, when everything is running well note down your working settings - It can be really handy if you have to come back to android / processing after a few weeks break and you can't remember which adb / sdk stuff was correct.

Sign In or Register to comment.