Urgent! Please Help!!! (windows 10 autoupdate woe)

edited May 2017 in Kinect

I'm presenting my graduation project on Wednesday. Everything has been working properly but today my Windows 10 started updating and after that I haven't been able to start the sketch: "Target VM failed to initialize". I'm using Kinect V2 with Open Kinect (basic kinect code from Shiffman maxthreshold). I assume the problem has something to do with libraries since another sketch error said that libraries are missing. However I have installed all libraries and nothing was wrong before the update. Please help, I'm panicking a bit since I need to present my work the day after tomorrow! I'm not enclosing the code since it's really long and there should be any problems with the code. Thank you so much!!


  • This is a good opportunity for you to check previous posts and get a simple useful code that works with your kinect V2 module. A simple sketch interacting with this module is important and it should be part of your tools in your project. This side code can be used any time when running into this kind of problems. It will make debugging easier as there is no overhead operations from other parts of your code, for example.

    Your error message is really not that useful without knowing anything about your code. Please also drop the uppercase in the title. I would suggest you mention the importance in the first line of your post, not in your title.


  • Thank you for your response! I tried opening the basic MinMaxThreshold sketch by Shiffmann with no added code and it's not working properly anymore either. So it's something else than the code itself. I tried reinstalling the libusbK driver and openkinect library but it haven't helped either. I just can't get my head around what the problem is. I'd really appreciate your help!

  • Seems that there's problem with this line of code: kinect2 = new Kinect2(this); "A library relies on native code that's not available"

  • Did you install the lib?

    Sure it's kinect2 !?

  • Thanks @Chrisir for the answer. I reinstalled all the libraries and yes, it is kinect2. The thing is, everything was working fine before the Windows 10 update (bootcamp), and after that I can't get any sketches with openkinect working.

  • Does processing alone work with a simple sketch?

    might be a antivirus software

  • Yes it does, all other sketches except for the ones using openkinect are working. I reinstalled Processing and all the related libraries as well but it didn't help either.

  • does kinect work with its other applications...?

  • According to SDK configuration verifier everything else is working except for the depth sensor. Here's the whole processing error message attached, for me it seems to have something to do with the paths/ openkinect libraries? IMG_5104

  • no idea


  • I restored Windows to its previous build and the sketch started working again! I'm so relieved now but still very curious about what happened with the update, especially since it seems impossible to disable Windows updates. If anyone has any experience with this, would love to know. And @kfrajer sorry about yelling in the title, got a bit stressed about having nothing to show in my graduation seminar. :) Thank you @Chrisir and @kfrajer for your help.

  • Good to hear it is working again. It is bad that stuff like this happens and code stops working all of the sudden. It doesn't help that kinect support here in the community is not very much. Sooner or later, whatever the update did to break kinetic, will be resolved (fingers crossed).

    For stopping windows updates, check this: https://www.google.ca/?gws_rd=ssl#safe=active&q=windows+10+stop+automatic+updates&spf=388

    Good luck in your presentation.


Sign In or Register to comment.