Lost connection with device while installing (I have not found solutions in previous questions)

edited May 1 in Android Mode

With the update of processing i have problems to connect the device in android mode. Also the emulator didn't run. The errors:

Failure [INSTALL_FAILED_DEXOPT] Shutting down any existing adb server... Exception in thread "AndroidDevice: logcat process monitor" java.lang.IllegalStateException: I didn't know about device UBE0216329000293! at processing.mode.android.Devices.deviceRemoved(Devices.java:266) at processing.mode.android.Device.shutdown(Device.java:295) at processing.mode.android.Device$1.run(Device.java:278) at java.lang.Thread.run(Thread.java:748)

This also happens with a simple sketch with only the setup() so I think there are no code problems. The SDK was downloaded automatically and before the update all works correctly. Please, someone can help me? (Yes, usb debug is on)

Tagged:

Answers

  • before the update ?

    This is a very important piece of info. What update? If you revert back to the prev version, would that fix the issue?

    Also https://forum.processing.org/two/discussion/21588/running-sketches-on-my-smartphone-does-not-work-anymore#latest


    Processing version

    Android mode Version

    Operating system

    Target APIs you have tried (Installed through the Android SDK manager and visible in the Processing IDE Android mode)

    Android SDK version. Did you install it yourself or using the automatic installation offered by the Processing IDE android mode?

    Have you run Android apps in Processing before? In any other SDK like Eclipse or Android Studio (AS)?

    Is this your first time? Did you enabled the developer mode in your device?

    did you check the following website as a reference: http://android.processing.org/install.html Did you try any other set of instructions? Which ones? Can you provide your link?

    Are you running your app in an actual device or through an emulator? (NOTE: It is strongly recommended to do it on an actual device)

    In case you found something meaningful in the forum or in other site, please provide links (If nothing found... leave blank).

    Have you tried anything else? For example, renaming/removing the manifest and letting Processing recreate the manifest for you again? (To access the manifest, press ctrl+k in your sketch and there should be a file called "manifest.xml")

    EDITED:****** Extra questions as suggested by akenaton

    Have you activated the debug mode on your phone + what is your phone OS ? ) + give us more error code (not only the first 2 lines)

    Kf

  • edited April 30

    The update is the 3.3.2, before I had the 3.3.1. After your comment I have uninstall processing (the folder too) and I have install the 3.3.1, but now give me the same error and I don't understand why. Now the message is:

    Failure [INSTALL_FAILED_DEXOPT] Shutting down any existing adb server...

  • Hello I have the same problem after the same update than you Just remove from sdk manager the android sdk platform tools and the build tools version 26 rc1 in the preview channel And install the 25.2.5 After that restart Processing 3.3.3 and it's work again for me Good luck

Sign In or Register to comment.