Python 3 code not running in Processing 3.2.4 on Mac OS 10.12.3

edited February 2017 in Python Mode

I have been trying to get code like size(200,200) to run in Processing in Python Mode. I have installed Python 3 in Contribution Manager and I have tried deleting and re-downloading Processing. When I attempt to run the code, the Run arrow turns green, but no window appears. How do I get up and running with this?



  • I am having the exact same problem. If you try running a basic line of Java code in the Java mode it will work. It's just the Python mode that won't show the sketch. And yes, the green arrow is lit but nothing comes up. I tried uninstalling Python mode and reinstalling and also uninstalling Processing too. Nothing has worked yet.

  • If you are using a PC, a student of mine found that if he right clicked Processing and clicked "run as administrator" that this problem went away. I'm still not sure how to fix it on a Mac.

  • there have been reported problems with firewalls and / or anti virus stopping processing from working.

    i don't have a mac so don't know where to suggest looking for errors that may be logged somewhere regarding the above.

  • Hi, folks. I'm sorry to hear about these problems, and would love to understand and fix them.

    Out of curiosity, are you using Windows, and does your user name contain non-English characters (such as Chinese or accented Latin characters)?

  • I have the same problem with processing 3.3 on macOS 10.12.4. no non-English characters in user- or filename.

  • @koogs I shut down the mac's firewall and LittleSnitch, no additional anti-virus software running. Still no luck. Any other ideas?

  • If you have a print in setup, does it print to the console?

  • No. It just does not react. Even the play button remains green on white, as if waiting for the script to finish. See also this thread:

  • I, too, am having difficulties running Processing Python sketches after upgrading to Processing 3.3.3 with Python Mode Build 3022 on OS X 10.12.5. Python mode wasn't working after upgrading so I reinstalled Processing and Python mode from scratch after removing plist files in Library.

    Symptoms: Processing launches, and Java-based sketches run as they should, and it's possible to switch into Python mode. From there, one can write sketches or load examples from the menu, but sketches don't run, not even a simple ellipse command or any of the included examples. Eleven blank lines of output are produced in the Console window each time, however.

    Thanks in advance for any help or suggestions!

  • Oh, and Processing stops responding when I try to quit it from Python mode. I have a couple of crash reports that I can share if that would be helpful.

  • edited May 2017

    Following up with a solution to my situation. I deleted (actually renamed) the old ~/Library/Processing folder, which forced a new one to be created the next time I launched the app. I'm not sure what was causing the issue. The old folder contained dozens of blank .err files, with the accompanying .out files reporting those blank lines from the console. Interesting.

    Anyway, hope this helps if someone has the same problem.

    Update: The issue is back. It's still unclear to me what the issue is. I have more crash reports available. :-/

  • Thxs for sharing your solution.


  • I'm still having enormous difficulties with Python mode in Processing. * MacBook Air running macOS 10.12.15 * Most recent Processing 3.3.5 * Most recent Python mode installed, Build 3025

    I'm a big fan of Processing: I've used it successfully in both my AP Computer Science (Java) classes and my Introductory (Python-based) CS classes, but as of this point in time, I can't even run a simple print("Hello, world!") or ellipse(20, 30, 10, 10) instruction while in Python mode.

    I've rebooted the machine, I've launched Processing from a new user account, and the behavior is the same: Click on the Run triangle, it turns green, ten blank lines are written to the Console, and nothing else happens. No graphics window, no output. The green Run triangle will turn black if the Stop square is clicked, but that's it.

    I run Windows 10 in Virtual Box on my machine, and Python mode in Processing (64-bit) works just fine there. But the Mac version is having issues.

    I'd be happy to send along whatever logs, etc. would help troubleshoot this.

    Thanks for all the work you've done bringing Python mode to Processing, Jonathan.



  • Update: I tried to run Python mode in Processing this morning and it worked fine. Wrote a great little program to convert a list of values to a bar graph. Saved it, ran it several times. Did a screen capture of the output. Quit Processing.

    Re-opened Processing, selected "File > Open Recent" to load up the program again. It loads, but won't run. Run Triangle turns green, but no output produced.


Sign In or Register to comment.