Problem with Midi Bus library

edited December 2013 in Library Questions

Hi people, i'm new to the forum and to Processing (literally just started to get into it a few days ago). I tried to use themidibus library, but when i try to compile the Basic sketch, an error comes up saying: A library relies on native code that's not available. Or only works properly when the sketch is run as a 32-bit application.

also in the bottom red bar it says "the library used by this sketch is not installed properly".

I'm pretty sure i installed everything right and I uninstalled Mandolane too (which took care of some other errors), but i can't find a solution for this.

again, sorry for being stupid , but i'm absolute new to this. any help is much appreciated!

Thanks Balint


  • Did you install the library through the Processing library manager? What Processing version/OS are you using?

  • Perhaps install the 32-bit version of Processing (you don't tell us what version you use, nor on which system).

  • yeah sorry, i'm on OSX 10.7.5 and i'm using processing 2.1 and i believe there was no 64/32 bit choice at the download page on also it doesn't say in the 'About' tab. I installed it through the Processing library manager

  • actually it's OSX 10.8.5, sorry

  • Hmm, I've been running it on 10.9 with no issues. Maybe try removing and reinstalling the library. There's only the one version of Processing for OS X but the 32/64 bit thing shouldn't be an issue.

  • I've tried to reinstall several times, still no luck:( i have no idea what's going on

  • Thanks duaneram! i'll do the same

  • I know this is late but I got the same problem when I installed the MMJ library by copying and pasting the files libmmj.jnilib and mmj.jar in Library/Java/Extensions.

  • Is there any way to push that to google? :-) It cost me a few hours until I found this post which solved the problem (had those files in ~/Library/Java/Extensions, something else must have put them there in 2009...)

Sign In or Register to comment.