How to install processing-java in windows 10?

edited April 2016 in Using Processing

Hi Team,

I am using windows 10 and I want to install processing-java on my machine.

I know in download folder we have something processing-java.exe, when I double clicks on it. A black window opens and close within fraction of seconds. After this I try executing command processing-java in CMD (aka terminal) I am getting following messages.

"processing-java is not recognized as an internal or external command, operable program or batch file"

Usually we get this error when something in not installed on machine. So I think processing-java.exe file is not installing this to my machine.

I tried opening processing-java.exe in notepad (crazy idea!) I find something like, "Classpath not defined." and "This application was configured to use a bundled Java Runtime Environment but the runtime is missing or corrupted. If running from a folder with non-ASCII characters, try moving this folder to another location. Required files could not be found. If running from a folder with non-ASCII characters, try moving this folder to another location. The registry refers to a nonexistent Java installation or the runtime is corrupted."

I tried pasting the processing-java.exe in folder where java is installed then on executing command processing-java I am getting below:

Error: Could not find or load main class

Can please look into this and help me? Thanks in advance.



  • Processing is a standalone IDE. We need to decompress the downloaded ".zip" file before running it.

  • Hi. I am talking about processing-java.. Processing is working fine for me.

  • I'm using Windows 10 and it works perfectly here.

    • Do you have a JRE installed? Processing ships with its own java runtime environment which might not work with processing-java but I'm not sure

    • Not sure what opening the binary .exe in notepad would achieve. I suppose there are some built in error messages...

    • Is processing-java.exe in the same folder as processing.exe? Otherwise it can't find its own java runtime

  • Hi colouredmirrorball ,

    Yes, I have JRE on my machine plus processing.exe and processing-java.exe are in same folder.

    I was wondering if we need to create new environment variable for processing-java? can you please tell exactly what steps you performed to install the same on your windows machine. If it is working for you then I must be doing something silly.


  • What exactly are you doing? I run processing-java.exe through a command prompt and get this output:

    Command line edition for Processing 0248 (Java Mode)
    --help               Show this help text. Congratulations.
    --sketch=<name>      Specify the sketch folder (required)
    --output=<name>      Specify the output folder (optional and
                         cannot be the same as the sketch folder.)
    --force              The sketch will not build if the output
                         folder already exists, because the contents
                         will be replaced. This option erases the
                         folder first. Use with extreme caution!
    --build              Preprocess and compile a sketch into .class files.
    --run                Preprocess, compile, and run a sketch.
    --present            Preprocess, compile, and run a sketch in presentation mode.
    --export             Export an application.
    --no-java            Do not embed Java. Use at your own risk!
    --platform           Specify the platform (export to application only).
                         Should be one of 'windows', 'macosx', or 'linux'.
    The --build, --run, --present, or --export must be the final parameter
    passed to Processing. Arguments passed following one of those four will
    be passed through to the sketch itself, and therefore available to the
    sketch via the 'args' field. To pass options understood by PApplet.main(),
    write a custom main() method so that the preprocessor does not add one.

    No environment variables required. If you just use the java command, do you get the expected output or do you get an error too?

  • I'm trying to handle a similar issue, but I'm using iOS. Anytime I try to run processing-java in the terminal, I'm returned No such file or directory

    Any insight? The .exe file exists, it just refuses to run and I don't know why.

  • Had the same problem, you need to edit the Path system environment variable to add the processing file. Untitled

  • To get to the dialog box displayed in the previous post, you need to access Advanced System Settings, which you can access it by typing it in the search bar right after you click your Windows logo. Then, you click in the button right at the bottom: Environmental variables... and you get the dialog that is displayed in the previous post.


  • 2016...

Sign In or Register to comment.